"invalid field name" or "multipart identifier <xxx> could not be bound" on calculated field insert

Sometimes clients will get this error when adding a column with a freehand SQL calculated field to a report.

    "multipart identifier <field_name> could not be found" occurs at the report level.

    "invalid field name" will throw at the view level.

Either way, the underlying cause is the same: this calculated field is dependent on a table field that is not passing to Yellowfin as desired. Often this stems from having a large view that is set as "optimized." When creating a simple calculated field, the dependencies are checked during validation, but this process does not occur with a freehand statement.

In order to resolve, this table will need to be "forced" into Yellowfin's consciousness, there are a few ways to do this:

    You'll want to identify the table from which this field is based on first.

    The quick workaround - add more than one field from the affected table to the report.

    If there's only one or two tables / columns, you can go to the view, select the table, and check the "mandatory" box.

    If there are a lot of calculated fields across multiple tables, your best bet may be to disable the "optimize view" option from the     "model" tab of the view builder.

There's a task for this issue in dev land currently, so this article may be deprecated eventually. 

Is article helpful?