Performance to open dashboards

Ederson Kamphorst shared this problem 21 months ago
Resolved

hi folks,

I have a lot of problems when I open dashboards, it is too slowly. the same SQL scripts that the dashboard runs are very fast, something about 4 seconds. But the dashboard needs something about 30 seconds to load all reports.

When I look to the tomcat logs, without debug, I see a loot of lines reporting "Null reference code requested", can this be the problem?

Comments (1)

photo
1

Hi Ederson,

The warning you refer to is very common and will not cause performance delays.

I think the best route here will be to run our info threads tool for the duration of this report load:

https://community.yellowfinbi.com/knowledge-base/article/infothreadrunner

Can you collect these, zip the files up, and send them to me? Hopefully this will tell us what is taking so much time.

Regards,

Nathan

photo
1

Hi Nathan,

this is the generated file.

Thank you for now.

photo
1

Hi Ederson,

It looks like there is a lot going on during this time though none of these are a sole culprit.

Could you please zip and send me your entire logs folder? (youryfinstall/appserver/logs)

My guess is that this more has to do with a backed up queue at some point in the process.

Regards,

Nathan

photo
1

Ok,

If you need, I can activate the Debug logs.

Files: logs.zip
photo
1

Hi Ederson,

I assume that you are using the vertica DB for this dashboard?

Looking through the source log for this (source.70016.log) we can see this error very frequently:

2018-01-25 13:12:51 WARN: [70016] [1568] No connections available. Waiting for a connection to be returned.
2018-01-25 13:12:51 WARN: [70016] [1571] No connections available. Waiting for a connection to be returned.
2018-01-25 13:12:52 WARN: [70016] [1568] No connections available. Waiting for a connection to be returned.

This means that Yellowfin is attempting to create a connection to the DB to run a report's SQL query, but cannot connect until another connection has been opened.

I would recommend going to the data source settings for this specific data source and increasing max connections to the 25-50 range.

Let me know if this helps.

Regards,

Nathan

photo
1

Hi Nathan,

thanks for the help, I did not configure the connection pool parameters after I reinstall the 7.4 version. It was executing only 5 queries at a time. Sorry about that.

photo
1

Hi Ederson,


All good! Let me know if you run into any more problems with this.

Nathan

photo