Select source to create a view take long long time

Mario Navarro shared this problem 14 months ago
Resolved

d

Comments (10)

photo
1

Hi Mario,

Thanks for reaching out. I see there's no description or comment here, probably because we're having issues with Chrome inputting comments. Until we update our Community site, which should happen soon, please either use another browser or attach comments as an .rtf. or .doc file.

Can you please respond with your Yellowfin build? You can find this information under Application Details in your info.jsp file, which can be accessed by appending '/info.jsp' to your login URL. For example, localhost:8080/info.jsp. You can also find this info under Administration > System Information.

Can you also re-replicate this issue then provide a compressed copy of your entire logs folder, located at <YellowfinInstall>/appserver/logs so we can investigate further? I would guess if this action is taking a long time you're experiencing some connection instability with your data sources and/or config db.

Both of the above pieces of info will be the most helpful in determining next steps. I look forward to your response.

Regards,

Mike

photo
1

Hi Mike

Yes, I have noticed the problem with chrome.

The yellowfin build: 20180313 and version 7.4

I send you the log files.

photo
1

Hi Mario,

Thanks for supplying these. Connection instability does indeed appear to be the issue here:

/H0QaqkOB0oDwAAAAAElFTkSuQmCC

There's also a corresponding connection error in the source.202810 log.

As such, we do have a configuration to help mitigate this behavior, which should make it so this screen does not take as long to load. The configuration you'll need to enable is Volatile Data Sources.

Volatile Data Sources is a configuration setting that tells Yellowfin to check all of the data source connections every 30 seconds and, if a connection is bad or closed, to reset that connection.

Please follow the steps in the article linked above to enable this. After restarting the Yellowfin server and re-attempting this please let me know if you're seeing improvement.

Regards,

Mike

photo
1

Hi Mike,

I have enabled the Volatile Data Sources but I continue with the problem. (I restarted the database and yellowfin).

I send you the log file.


/D9qZMgX5TckDAAAAABJRU5ErkJggg==


photo
1

Hi Mario,

Thanks for confirming. We do have a tool available to us which will tell us exactly what processes are being executed at a specific time during a given action. Please download our InfoThreads Runner.

Once you pull up the runner, queue up to the point in the application right before you click to go create a new View. Set the output location in the tool. You can set the pages to 99 and seconds to 1. Click 'Go' then immediately click the create View button. You can stop the runner as soon as it's done being loaded.

Also, just to clarify as it's not stated, what is meant by long? 20 seconds, 40 seconds?

Regards,

Mike

photo
1

Hi Mike

I send you the files

photo
1

Question : Also, just to clarify as it's not stated, what is meant by long? 20 seconds, 40 seconds?

Answer: The process takes 30 min to 1 hour to show the objects of the database (sometimes appear blank screen and I need to start again). I don't need to see all database objects, I have the name of the object that I want to use in the view but I don't have the option to filter only the object that I want. (I have the option after to wait more than 30min).


photo
photo
1

Hi Mario,

Sorry, one more thing, can you please send me the information found under System Properties in your info.jsp file, which can be accessed by appending '/info.jsp' to your login URL. For example, localhost:8080/info.jsp

Thanks,

Mike

photo
1

Hi Mike, I send you the file.

photo
photo
1

Hi Mario,

Thanks for sending this. I believe the issue is that your JVM Max Memory is set to far below our minimum recommended setting. This is your current setting:

JVM max memory:989.9 MB

We recommend a minimum of 4GB be allocated to the application. Please follow the steps found in this knowledge base article to increase your JVM Max Memory setting to 4GB.

Please let me know you see improvement after doing so.


Regards,

Mike

photo
1

Hi Mario,

I just wanted to check in and see how things are going with this.

Regards,

Mike

photo
1

Hi Mario,

I'm going to go ahead and mark this one as Resolved since I haven't heard back from you, but if you have further questions or concerns on this, if you respond, it will re-open the case and put it back in my queue and I'll be happy to help.

Regards,

Mike