Is it possible to have a enclosure tab for CSV exports

Bharath Kumar shared this idea 8 months ago
Idea Logged

Hi Team,

We have some requirement to show csv output with enclosures.

Separator ( , or ; or | )

Enclosures ( ‘ ’ or “ “ or | | )

Examples

Case 1

"field1"|"field 2"|"OPERANDO field"|"MICROONDAS ERI"|"TRANSMISION"

Case 2

‘field1’;’field 2’;’OPERANDO field’;’MICROONDAS ERI’;’TRANSMISION’

Case 3

“MTR725 1”,” ’MTR725 AALACRHC”,” OPERANDO”,” MICROONDAS ERI”

Case 4

|ONE|,|MRTSDR|,|19982|,|2309|

I see currently we can only change the separator and input any symbol. But is it possible to have an enclosure tab within the export csv window where we can define a enclosure value?

Thanks,

Bharath

Comments (10)

photo
1

Hi Bharath,

Currenty we do not have any options available for an enclosure tab for CSV exports. This might be a good enhancement request. Would you like me to raise this as an Idea for you?

Regards,

Paul

photo
1

Hi Paul,

Thanks for the response. Yes, can this be raised as enhancement request and could you also please share the RFE ID.

Regards,


Bharath

photo
1

Hi Bharath,

This has now been raised as an idea. If there is any movement on this, I will advise you accordingly.

Your Reference is : YFN-14514

Regards,

Paul

photo
1

Hi Paul,

Apart from enclosures issues in CSV formatting, another important issues that we have is…

that CSV export in YF always exports all the field values in the first column of the excel file.

We also need reports in CSV format where individual fields are displayed in separate columns. Kindly do include this feature as well in the enhancement request.

Regards,


Bharath

photo
1

Hi Bharath,

Thanks for the info. Do you have any images or something in more detail on this one please as I am not 100% sure what you mean here.

Thank you,

Paul

photo
1

Hi Paul,

I have attached a sample report. As you can see the CSV export always exports all the field values in the first column of the excel file. Can there be an option to include

individual fields are displayed in separate columns.

Regards,


Bharath

photo
1

Hi Bharath,

Thanks for the sample. I will raise a seperate request for this as it is quite different to the first. Is there any reason you cannot run this through an ETL step as discussed here and then use this to eport into a spreadsheet?

As an example.

fc977a944fbe19a11f61c8a5d689c6ccCheers,

Paul

photo
1

Hi Paul,

This functionality is disabled in our build. I cant see the transformation steps.

Regards,


Bharath

photo
1

Hi Bharath,

Please check here to make sure the Role has been setup correctly. Let me know if you need durther help on this.

Thanks,

Paul

photo
1

Hi Paul,


This is not really helpfu to us:(


Regards,

Bharath

photo
1

Hi Bharath,


Let me try and assist here while Paul is out.

Can I confirm the issue here is that the .csv file is not showing values in separate columns when using a separator other than ,

Because in this case, I don't think the issue is on the YF side, but just a matter with how you're opening in Excel.

When using a separator other than a comma, excel will treat it as text. So in these cases you need to use the text to column option:


0416da94c9a93319715a07d0188a6fc0


In terms of the role settings, this was in relation to enabling Data Transformation. Though keep in mind this feature is only included in releases 7.4 and later.


Does this all make sense or am I misunderstanding the reason why you want to add an enclosure option.


Thanks,

David

photo