Color is not persistent with chart bars.

Kota, Aruna Kumari shared this question 27 days ago
Awaiting Reply

Hi Team,


I have a report with defined colored bars for each category.

When I run the report and there is data for all categories, all colors work as designed. However, if there are no data, the colors are shown for different categories. attached is an example of incident priority report which shows that the “Critical” is red and it works fine in the first chart, however, in the second report where there was no values for Low or High, the “Critical” category took the color of “Medium” which is yellow and the value of Medium took the color of “Low” since there was no “Low”.


Environment Details:

Yellowfin : 8.0.4.

Comments (9)

photo
1

Hi,

Somewhere I have seen that it is YF defect logged in YF 7.x and 8.x version. This has been fixed in latest YF 9.1 release.


Please correct me if I am wrong? If it is defect can you help me if you have any workaround for this.


Regards,

Aruna

photo
1

Hi Team,

Any update.

Regards,

Aruna

photo
1

Hi Aruna,

Hope you're well!

Unfortunately it looks like the attachment didn't get uploaded correctly and it's not a part of the ticket. Would you be able to try to upload it again, please?

We had more than a couple chart colour issues fixed in 9.1, would you be able to tell me where you saw that this problem was fixed?

Also what chart types were you seeing this problem on?

Are you still seeing in this in the newest BMC builds? i.e. 8.0.6.

Apologies for so many questions!

Kind regards,

Chris

photo
1

Hi Chris,


I tested this on YF 8.0.8 release and noticed same behavior. Please refer attached document.


Regards

Pratiksha

photo
1

Hi Pratiksha,

I'm not sure this is a bug; if you want to specify the colours for your series, you can do so in the series settings. If you use the default colours, then yes they will change depending on the data displayed.

Please see my screenshot below for what I mean:

/d398c1cc9944c49c61781aa6579b10beIf it is a bug, were you able to tell me where you saw that it was fixed for 9.1?

Kind regards,

Chris

photo
1

Hi Chris,

This colour setting is available only for Metric fields and not for dimension. We are using Status and Priority field and can't find option to set the colour code. PFA

Can you check it at your end please ?

On one of the YF community link I found that it's fix in 9.1.


Regards

Pratiksha

photo
1

Hi Chris,

Any update on this issue?

Regards,

Aruna

photo
1

Hi Chris,


Any update on this issue please?


Regards,

Aruna

photo
1

Hi Aruna,

Apologies if I wasn't clear before.

You will need to set up a set of reference codes for the field, including the colours you want to use and then apply those reference codes to the field in the view. You will then be able to use reference code colours in your charts, as per below:

/64e312c18f355abc2bf09a64ae8fadc1


Please see our Wiki which covers reference codes here, and there is also this method described here for custom colours for dimensions.

I hope that helps!

Kind regards,

Chris