Cached filters no longer showing images post upgrade

David Registro shared this problem 3 years ago
Resolved

I upgraded from 7.1 to 7.3 and now my images next to my filter values are not showing.

Here is how it looked in 7.1:

2a7564be5c89aa39de1b48326098b385


Here is how it now looks in 7.3:

40cc9bad23c3accbebb900f3241f2412


How do I get it back?

Comments (1)

photo
1

The reason for this is a change in the 7.3 (and later) format options.

'Cached values' will no longer display the images, you will need to actually choose 'Reference Code' to display these. Reason being, the custom images are only every applied to reference codes, so it just makes sense to ensure the images are only shown when the filter itself is formatted as Reference code.

So fixing this is a matter of modifying your filter and changing from 'Cached Values' to 'Value List Selection'

b2a1a98f68fd02dcf7ec6a82d4aa8da5

You 'may' also need to change the Display option to 'Image & Text'

2fedbf402913237ecb4e0f08f93ecc4b

But how do I find reports/views in 7.1 that need to be updated?

The attached SQL queries can be run directly against the Yellowfin DB. Each query will return an affected filter name, and where it lives, whether it lives in a view, report or sub-query.


As always, if you still have issues with the above, or anything else, please contact us!

Regards,

David