Yellowfin is not working with Java 10

Yellowfin FAQ shared this problem 18 months ago
Resolved

I've just upgraded to Java 10, and now Yellowfin won't start. It immediately shuts down, and don't see any errors appear, or captured in the logs

Comments (4)

photo
1

Is this problem fixed. Is Yellowfin Compatible with Java 10 ?

photo
1

At this point in time, Yellowfin is not compatible with Java 10. We are investigating further and will post with any updates.


At this point in time you will need to use an older release.

If you have already installed Java 10 and need to point to an older release, just modify your relevant start up config to point to that release.

This can be done via catalina.sh, catalina.bat or your Windows service properties.

More info on this can be found here : Yellowfin is unable to start after Java Upgrade

If you run into further problems with this, or have any other questions, please let us know.


Regards,

David

photo
1

Thanks a lot David.

photo
1

No problems, once we get it all working I'll come back and update this post. Thanks

photo
photo
1

An update on this problem. It looks like it's all just working! No YF code change required.

We've tested it on over 10 machines with a bunch of different operating systems with both Yellowfin 7.3 & 7.4, and can confirm it just works.

If you are still experiencing any issues with Java 10 and Yellowfin, please raise a private ticket with us and include the following information:

-Any screenshots or errors you think are relevant

-All YF logs under \yellowfin\appserver\logs

-Related information, such as ; Worked up until.... Can confirm it works when...


We will then be able to assist further.


Thanks,

David