Yellowfin and Java 9 Compatibility

Mark McGuire shared this problem 2 years ago
Resolved

I am curious to know if Yellowfin is compatible with Java's recent release of Java 9?

Comments (5)

photo
1

As of yet Java 9 is not currently compatible with Yellowfin. We would recommend using Java 8 whilst we address this issue.

For instructions on how to update your Yellowfin Java settings please see this article:

https://community.yellowfinbi.com/knowledge-base/article/yellowfin-is-unable-to-start-after-upgrade-to-latest-java-version

We have logged this with our devs and we can track this with the JIRA ID of; YFN-7926

Regards,

Mark

photo
1

Update

Java 9 working in our scheduled November EOM build for 7.3 and 7.4 - We are still working through regression testing, so please bear with us.

Regards,

Mark

photo
1

Hello Mark,

Just wanted to confirm if Yellowfin is supporting Java 9, if yes what are the version of Yellowfin which support Java 9

regards,

Sarath.

Quantum Secure.

photo
1

Hi Sarath,

I hope all is well,

I can confirm that this was released in our November EOM build for 7.3 and 7.4.

Regards,

Mark

photo
1

UPDATE

It appears we are still facing issues with Java 9 and 7.3/7.4, it appears to be working for some and not for others... We will further investigate this.

Regards,

Mark

photo
1

Hello Mark,


Thanks for the update, can you confirm what the ETA for this items, as we have promised our customer to finish this activity by Feb 28th 2018.


regards,

Sarath.

photo
1

Hi Sarath,

As of yet theres no ETA to give with regards to the troubles around Java 9, as stated this appears to work for some and not for others... At this stage it is a case of testing, testing and testing to see if anything breaks and prompts us with errors.

I would highly recommend rolling back your Java if you encounter any issues whilst we further test.

Regards,

Mark

photo
1

Hello Mark,


One observation which I wanted to share. When we did a migration from 6.3 directly to 7.3 we were observing that the underlying tomcat is still remaining as 6.3 and not 7.x. Can this be one such reason why it is working for few and not working for others.


regards,

Sarath

photo
1

Hi Sarath,

Thank you for bringing this to our attention. This is standard and always works like this when upgrading... As of now we only have one user with Java 9 problems, and this seems to be around Data Transformation.

Our original statement still stands hence our update on where we stand. Apologies to all for any issues that this has caused.

787fdb7b9a954ea03af96964adac1980

Regards,

Mark

photo