Why the older functionalities have been removed?

Pushpal Kumbhare shared this idea 2 months ago
Idea Logged

Dear  Team,

I have created a content folder in the 9.1 version just like I have in the older version 7.2.

While testing it shows that a particular report which is in a content folder having access to limited users, shows a message as below 'No Access'.

In older versions, it simply used to hide the report which serves the purpose of hiding the report on the same dashboard from a user.

But now in 9.1 version, it does not hide the report, rather shows the report and says 'No Access'.

So now to hide this message and report, we will have to create another dashboard(without this report) for that user who will not have access to the reports.

0765fb525ee1066d7b39f45d51ecff5b

And my question is again: why are new versions ruining/removing the very good functionalities of older versions and making it worse and complicated for developers?

--

Regards

Pushpal

Comments (11)

photo
0

Hi Pushpal,

I hope all is well,

Unfortunately I can't get an exact answer as to why we have older functions removed within version 9, however going forward we have made changes to better the product and to help improve performance.

Going forward with this issue would you like me to investigate further? Maybe an idea to have this back with our development team? Let me know.

With this I am happy to discuss further in a different ticket about all areas affected to see what we can do. Let me know.

Regards,

Mark

photo
0

Hi Mark,

Can you please let me know how I fix the issue of hiding the report on the dashboard for a particular user in 9.1 version?

I am not able to hide the report for a user. It appears on the dashboard saying 'No Access'.

Please advise, how to hide the report from a user on a dashboard.

photo
0

Dear Team,

Any updates on this?

photo
0

Dear Team,

Any updates on this?

We are stuck due to this issue and cannot go further migrating on 9.2/9.1

photo
0

Hi Pushpal,

Apologies for the delay... Following your steps via your original message I am currently trying to figure out how we can achieve this in our latest version 9.

Regards,

Mark

photo
0

Hi Pushpal,

I hope all is well,

I have looked into this further and I can confirm that this is the case with version 9, users that do not have access to this specific report within a dashboard does get the message of "No Access" see image below:

206d2b1131be9919ab622f4badbe1642

Because of this I will test in older version of Yellowfin to see what behaviour we get, however I will also look at how we can avoid seeing this warning of "No Access"

I will update you very soon.

Regards,

Mark

photo
0

Hi Pushpal,

I hope all is well,

I have just checked this in 7.3.17 20190719 and I get the following results:

1462546c37a36ca30ef212bb8a80a473

From what we can see it does not give you the "No Access" message as stated. Going forward with this I will question this with our development team as to what options we have.

Regards,

Mark

photo
0

Thanks Mark !

You now see that some older version features are removed in 9x versions.

That was actually a good feature in older versions.

photo
0

Hi Pushoal,

I have since had an update on this and it appears to be expecte dbehaviour with how we want this feature to work... Going forward I can understand how this can be a shock to the system, considering this was not the way it worked in previous version.

Because of this we have 2 options;

  1. We raise this as an Enhancement to have the feature back.
  2. CSS could potentially be used to correct this.

Let me know your thoughts Pushpal.

Regards,

Mark

photo
0

Hi Mark,

Please raise an enhancement request and defect in 9x versions.

This feature should be back. Not sure what made developers remove this wonderful feature.

photo
0

Hi Pushpal,

I hope all is well,

I have gone ahead and logged this as an enhancement feature, you can find this ticket here.

Going forward I will mark this ticket as Enhancement Logged.

Regards,

Mark