Update Yellowfin - "Your installation does not require this patch."

Renato Marcello dos Reis shared this problem 3 months ago
Defect Logged

Hi Guys,

I was trying to test the new version of Yellowfin 8. Actualy, I'm using 7.3+ build 20181120. Before I tried to achieve the version 8, I've upgraded to 7.4 build 20181221. When I try to apply the update version of the Yellowfin 8 Installer build 20181113, the system says that I don't require this patch to update my Yellowfin 7.4 version.


What can I do to update to version 8? I've attached a print showing the error message.


Thanks in advance.

Files: Erro.png
Best Answer
photo

Hi Renato,


Thanks for reaching out with your issue.

I found the source of the message you received in our installer -


installer.builddate.too.high=Your ${installer.appname} installation does not require this patch.
It looks like the issue is related to the installer not liking the build date difference between your versions; as the running 7.3+ 20181120 instance is technically newer than the 8.0 2018113 build you are trying to update to. I tested this behavior with an attempt to update a 7.4 instance to an "older" version of 8.0 and received the same error message as in your attachment.


A solution that worked for me was to download a version of 8.0 with a newer build date than the 7.4 instance I was running. This allowed the build date check to complete successfully. Unfortunately, the issue here is that there is currently no newer release (build date) for 8.0 than the 7.4 update you are running.


I checked our development system, and found a bug report for this exact issue, from a time where we had a build date gap like this between two previous versions. I've updated this task with the information you've provided, and included you as an affected client. Updates to the task will be provided through this thread.


Barring waiting for a bug fix, there are 3 potential resolutions as I see it -


1. Postpone upgrade until the next 8.0 build is released - end of Jan est.

2. If possible, roll back running YF instance to a build date before 20181120

3. Install new, full 8.0 instance and import content

Apologies for the complications here, but thanks for bringing this issue "back" to our awareness.


Thanks,

Eric

Comments (3)

photo
1

Hi Renato,


Thanks for reaching out with your issue.

I found the source of the message you received in our installer -


installer.builddate.too.high=Your ${installer.appname} installation does not require this patch.
It looks like the issue is related to the installer not liking the build date difference between your versions; as the running 7.3+ 20181120 instance is technically newer than the 8.0 2018113 build you are trying to update to. I tested this behavior with an attempt to update a 7.4 instance to an "older" version of 8.0 and received the same error message as in your attachment.


A solution that worked for me was to download a version of 8.0 with a newer build date than the 7.4 instance I was running. This allowed the build date check to complete successfully. Unfortunately, the issue here is that there is currently no newer release (build date) for 8.0 than the 7.4 update you are running.


I checked our development system, and found a bug report for this exact issue, from a time where we had a build date gap like this between two previous versions. I've updated this task with the information you've provided, and included you as an affected client. Updates to the task will be provided through this thread.


Barring waiting for a bug fix, there are 3 potential resolutions as I see it -


1. Postpone upgrade until the next 8.0 build is released - end of Jan est.

2. If possible, roll back running YF instance to a build date before 20181120

3. Install new, full 8.0 instance and import content

Apologies for the complications here, but thanks for bringing this issue "back" to our awareness.


Thanks,

Eric

photo
1

Hi Eric.

I'm going to wait until the next release in this case so I can continue to test the new features in 7.4 version.

Thanks a lot for your assistance.

photo
1

Glad to assist, Renato, although I do wish I had a better solution for you! Thank you for understanding, and thanks again for reporting the issue.


I will mark this ticket as Defect Logged. Feel welcome to reach out with any issues you may encounter in your 7.4 testing.


Best,


Eric

photo