Tooltip on crosstab charts should show the "Color" instead of the "Vertical Axis"

Johnathon Warren shared this problem 1 year ago
Defect Fixed

When using crosstab charts, mousing over a column shows all the values for that value in the "Horizontal Axis". This is a very useful improvement, btw, we love it!

The only problem, is that when using a cross-tab report, the tool-tip tells me the label for the "Vertical Axis", instead of what I need, which is the "Color" that each value represents.

Now, this isn't very useful information, as you can see in the attached image. So I request that the labels in the tooltip mirror the values in the legend or "Color".

Also, if there was a way to shrink the tooltip when it gets so big, that would be great XD

Thanks and regards,

Comments (9)

photo
1

Hi Jonathon,


First of all, thanks for the feedback!

I'm having a little trouble understanding how you're seeing what you're seeing.


The tooltips for me in 7.4 actually show me both axis and metric values. See example below:

9602542cddeadf06ba39250bbacd7b5546a61b706a686bc0bc8bb04bc016f0ea


I'm sure I'm missing something here, apologies.


Thanks,

David

photo
1

Have a look at my attached screenshot in the OP.

My mouse is hovering over the "Feb 15" column so as to show all the values for that date.

Notice the repeated "Has Data" (which is what I called the cross-tab metric). This isn't useful at all. I need to see the "Infosource" value for each, paired with the "Has Data" value.

photo
1

Hi Jonathan,


Hope you've been well!

I've got some notes stating this was addressed in the latest 7.4.7 release.

I'm just wondering if you've had a chance to upgrade as yet and confirm this is the case.


Thanks,

David

photo
1

Haven't had a chance to upgrade our system until now. Unfortunately, a new, related, bug is occurring: https://community.yellowfinbi.com/topic/reference-codes-not-appearing-in-multi-value-tool-tips-for-charts

photo
1

Thanks Jonathan,


I'll test it all out and get back to you on this.

photo
photo
1

Hi Jonathan,


Ok looks like I was missing a key factor, this is a time series chart.

When it's time series, the tooltips work differently, as you are able to hover over the x-axis, and it will show you all data points for that time period.

However, it would expect to show multiple metrics,

E.g.

9dec03bd4b21e21cba03faea0433be21


When using a cross-tab, you're looking at multiple dimensions, and it's not catering for that. So I've raised a defect for it to be fixed.

I don't have an ETA as yet to when it will be fixed, it's in the queue. When there is any movement I can let you know.


Though if there was anything else you were after in the meantime, please let me know.


Regards,

David

photo
1

Thank you very much :)

photo
1

no probs, sorry for the inconvenience.


Regards,

David

photo
1

Ok I can confirm this issue itself is fixed. Tooltips will show the relevant color value.

3f341397d9fc36551a8d80387cf918f7

.....However as you mentioned, there is a problem when using reference codes, which has been logged and communication on that issue will continue via this topic.

In terms of this defect I'll flag it as fixed to help other users find this.


Thanks,

David

photo