Slow connection and database disconnects

Aaron Morgan shared this problem 3 months ago
Resolved

we are having an issue between yellowfin and the database, we regularly have to go to the data source and retry the connection to get data to show on reports as well in the log file i keep seeing "(DBAction:disconnect) - Terminating Database connection" every few seconds at least. should this be running as often as it is? we have volatile data sources turned on but it does not seem to be working.

Comments (5)

photo
1

Hi Aaron,

Thanks for reaching out. I'd be curious to know of your JVM Max Memory allocation. You can find this information under Application Details in your info.jsp file, which can be accessed by appending '/info.jsp' to your login URL. For example, localhost:8080/info.jsp. You can also find this info under Administration > System Information.

Please also provide a compressed copy of your entire logs folder, located at <YellowfinInstall>/appserver/logs as well so we can see if anything else appears to be going on behind the scenes. We also have another method of mitigating connection instability: JDBC Verify, so I'd like to see if that's been enabled as well.

Thanks,

Mike

photo
1

we have two different instances with different amounts of memory allocated between them but they are both having the same issue. as for the log files i have sent them in a ticket id: 12824-03-13. please email aaronmorgan@gov.nl.ca for the password. JDBC verify has not been activated.


what is the recommended amount of allocated memory for yellowfin.

photo
1

Hi Aaron,

I believe the lack of resources in the first place is the most likely culprit here. We recommend a minimum of 4GB of memory be allocated in production instances and 2GB to even be functional. You can read more on our Server Requirements Wiki.

Please follow these steps to increase your JVM Max Memory in both instances of Yellowfin and please let me know if you see improvement.

In terms of the logs, unfortunately you have DEBUG logging turned on, which creates a lot of noise and makes the entries very difficult to sift through. Should memory allocation prove to not be the only issue, then I'll need another copy of your logs sent without DEBUG turned on.

Please toggle off DEBUG logging by following these steps. I'll also request you do this even if we don't wind up requiring another copy of the logs for this case, as it's best to just have it turned off. We only recommend DEBUG being turned on in specific, and quite rare, cases, and then turned back off.

Please let me know results of increasing the JVM Max Memory.

Thanks,

Mike

photo
1

We have changed the memory to 4 gb and reports that were taking 5 min are now working in less than a minute and our instance feels a lot faster now. thanks for the help we really appreciate it!

photo
1

Hi Aaron,

You're welcome! Just to reiterate that is a baseline recommendation - the number should be increased depending on average analytical complexity of your reports (lots of calculated fields, sub-queries, advanced functions, etc.), max concurrent user counts, very large data sets, etc., but I'm glad you're seeing vast improvement thus far.

I'll go ahead and close this case out for now this considered, but if you have any further questions or concerns on this, please don't hesitate to reach back out.

Regards,

Mike