SELECT DISTINCT for View

Zack Wilson shared this problem 2 months ago
Defect Logged

I have a view that if "DISTINCT" were simply added to the SQL Query, I would not duplicate rows. I tried to turn on/off the "Show Duplicate Records" and nothing changed. How do I fix this?


-Zack

Comments (1)

photo
1

Hi Zack,

Thanks for reaching out.

You can toggle SELECT and SELECT DISTINCT in a reports SQL by clicking the 'Show Duplicate Records' option in the Report Builder:

/48916bcf186b969d09fba180343598f8

Off (Default) = SELECT DISTINCT

On = SELECT

At the View Level there's the Show Duplicate Records option in the View Options > Performance menu. However, I do see that toggling it does not change the SQL, so I suspect this to be defective.

As such, I've gone ahead and submitted a defect for this and hopefully using SELECT DISTINCT at the Report Level will be a suitable option for the time being.

Any potential updates regarding this will be posted here.

Regards,

Mike

photo
1

Thank you!

photo
1

Hi Zack,

You're welcome!

Regards,

Mike

photo