Multi Page sliders on dashboard

Marc Daverat shared this problem 5 months ago
Defect Fixed

Hi Team,

We limited a report to have only 10 records displayed at once and included it in a dashboard.

Page slider is displayed on top and bottom of the report, leading to vertical scrollbars. And there is also a page slider at the bottom of the widget.

/124e0bd9c104c9c807ab1405618ba4bb

/8fb3da687673379e85c55198a0673e22


We can discard the top slider at report level, but not the bottom one. We do not remember we had this issue on 9.2.

We are on 9.4.

Thanks for helping,

Marc

Comments (6)

photo
1

Hi Marc,

Thanks for reaching out to support with your issue. I was able to replicate this behavior with our tutorial content in, like 5 seconds -


52d5553bbc251668fff9869c5a963bc9

Yuck!

This felt familiar - I submitted a somewhat similar task to devs recently: when importing a dashboard with a multi-page report into 9.3, you got TWO sets of messed up nested scrollbars, on top of the two bottom page navigation buttons. So these two scenarios may have an overlapping root cause - something like a container parameter that needs to adjust differently for multi-page reports.

What's especially weird though - I had submitted and tested this in 9.3. No problems with the original content in that version, just after importing. So something has changed... I'm going to do a review of the 9.4 changelogs to see if anything sticks out. Apologies, I have been out the last two weeks on holiday, still getting caught up haha. I'll also talk to the team to see if they have any insight. At the end of the day though (sooner even), I think I'll need to either make a new bug report, or modify the existing one. Because this looks pretty big, and pretty bad.

Not sure if this situation is such on your end that you're considering a rollback?

Thanks.

Eric

photo
1

Hi Marc,

I've gone ahead and raised a task for developers to look into, in regards to this issue. Updates to the task will be provided here as they are available. I will in turn mark this ticket as Defect Logged for now. Feel welcome to reply here with any related inquiries.

Thanks,

Eric

photo
1

Thanks Eric, Happy New Year !

photo
1

Hi Marc,

Just wanted to provide an update - devs have come up with a fix for this issue and it will be included in upcoming 9.5 release. I'll keep this ticket open in the meantime.

Thanks,

Eric

photo
1

Hi Marc,

With the official release of 9.5, I'll go ahead and mark this ticket as Defect Fixed at this time.

Best,

Eric

photo
1

Hi Marc,


Just wanted to provide a small update - Yellowfin 9.5.1. is now available on our Downloads page.

We have addressed two issues that arose the time we released 9.5:

  • Resolved an issue that would prevent CSS files from loading in certain scenarios involving embedded content with JsAPI
  • Resolved an issue that prevented saving configuration settings on the System tab within client organizations due to ‘invalid value for maximum file upload size’ error

We'd recommend transitioning to this update if possible. For more information please see our release notes.

Looking at upgrading to 9.5.1 from 8 or previous versions? Please reach out to us as we’d love to assist you.

Thanks,

Eric