could not be bound

Mark Bunster shared this problem 1 year ago
Resolved

Trying to create a report from an ODBC source, but when I drag any of the fields from the single table that I've pulled, I get:


Error retrieving results

The multi-part identifier "STDRPT_WO_DETAIL.work_order_no" could not be bound.

Comments (4)

photo
1

Hi Mark,


Thanks for sending us an email.

1. Can you please send us all the log files?

2. Is this a new data source, and new View?

3. Have you changed names of the fields?

4. Do you have any pre-existing reports using the same view and fields? If Yes, does the report run ok?


Please send us the screenshots and the log files, I will investigate further and will let you know.


Let me know if you have any questions.


Regards,


Mahe

photo
1

Hi, thanks for the reply. I was working to set up a source in order to use the trial version. After working with Yellowfin staff, it turns out if you explicitly name the schema as part of the db name in the SQL, but do NOT name the schema as part of the field names, Yellowfin gets confused. We worked around the issue but it is one that the tech I worked with, forwarded to his development team.

photo
photo
1

Hi Mark,


Thanks for your reply.


My understanding is that you have now know the cause of the issue and the development team is looking into it.


If my understanding is wrong, then can you please explain me "if you explicitly name the schema as part of the db name in the SQL, but do NOT name the schema as part of the field names" with an example.

And let me know what database you are using.


If your issue is resolved and I don't have to investigate then, please ignore my question and let me know if I can close this ticket.


Let me know if you have any questions.


Regards,


Mahe

photo
1

Hi Mark,


Hope you are doing well.


Due to inactivity on this ticket, I am closing it.

If you have any issues, you can still reply back and this ticket will become active.


Please let me know if you have any questions.


Regards,


Mahe