Client Source Substitution not working in 7.3

Karthik Kannan shared this problem 4 months ago
Defect Fixed

Hi Yellowfin Team,


Created a primary organisation and a client organisation and tried to do the Client Data Source Substitution, but options are not available in the primary organisation.


Steps followed:

1. Create a Data Source Connection at the Primary Org level

2. Connections to redirect to at the Client Org level

3. logged in to the Primary Organisation and edit the Data Source to apply substitutions.


But the options shown in http://wiki.yellowfin.com.au/display/USER63/Content+Management are not available.


Thanks in Advance,

Karthik K

Comments (22)

photo
1

Hi Karthik,


Thanks for your email and thanks for letting us know that the wiki is not upto date. I will advise the department to update the wiki article.

Can you please tell me which build are you working on?


I have attached a quick video along with this email for your reference on creating a source substitution.


Please let me know if you have any questions or if that is not clear.


Regards,


Mahe

photo
1

Hi Mahe,


Thanks for your quick reply.


i'm using Yellowfin 7.3 (20170523).


Regards,


Karthik K.

photo
1

Hi Mahe,


In the Video Client and Data Source is displayed but in our yellowfin only Inherit Access Filters from client source is displayed. If you need to check anything in my yellowfin configuration then i will be available for TeamViewer / Anydesk Sessions.


Thanks in Advance,


Karthik K.

photo
1

Hi Karthik,


Just wondering if you have followed the steps in the video.


If you create a data source in the client org and then login back to default org, then you will see an option to select the data source.


Please let me know if you have any difficulty.


I believe you will be alright.


Regards,


Mahe

photo
1

Hi Mahe,


I did as per the instructions only. we renamed our default organization name that is the only difference. we need to do any more additional configurations ?


Regards,


Karthik K

photo
1

Hi Karthik,


I have just tested on the build 20170523 and it looks like a defect. I have tested on March build and was working fine.

Did you do a fresh install or did you do an update?


I have raised a defect ticket id: 6519 and will update you as soon as the issue is fixed.


Let me know if you have any questions.


Regards,


Mahe

photo
1

Hi Mahe,


I did a fresh Install.


Regards,

Karthik K

photo
1

Hi Karthik,


Thanks for the info, I have raised a defect.

I will update you once I hear from developers.


Let me know if I can help you with anything else.


Regards,


Mahe

photo
1

Hi Mahe,


Just wished to know about the status of the ticket, we are waiting for it.


Regards,

Karthik K

photo
photo
1

Hi Karthik,


Sorry, I don't have any update yet on this case.

As I know this issue will not be fixed in this July EOM build.

I will keep you posted as soon as I see the progress on this issue.


Please let me know if you have any questions.


Regards


Mahe

photo
1

Hi Mahe,


Just wished to know about the status of the ticket, we are waiting for it.


Regards,

Karthik K

photo
1

Hi Karthik,


Sorry again, no update about this.

Can you please tell me if this issue is a showstopper for you, or how big is the impact?

I will pass on that info to the developers.


However, I have made this request as highest in the queue.


Please let me know if I can help you with anything else.


Regards,


Mahe

photo
1

Hi Mahe,


Thanks for your reply.

We are creating reports for our multiple clients, so we found this Client Source Substitution is one of the best feature to achieve our task. This issue is a showstopper for us. please consider this issue as a high priority task.


Thanks & Regards,

Karthik K.

photo
1

Hi Karthik,


Thanks for your reply.

This issue is now in the top of the list for developers.


I will update you once this is fixed.


Regards,


Mahe

photo
1

Hi Mahe,


Thanks for your kind reply.

Just wished to know about the status of the ticket, we are waiting for it.


Thanks in Advance,

Karthik K

photo
photo
1

Hi Karthik,


Thanks for your patience.

This fix will be available in the August End of Month build.


I will let you once it is released.


Please let me know if you have any questions.


Regards,


Mahe

photo
1

Hi Mahe,

Thanks for your kind reply.

Just wished to know about the status of the ticket, we are waiting for it.

Thanks in Advance,

Karthik K

photo
photo
1

Hi Karthik,

Yes, this issue has been fixed and is now available in the August EOM build.

Please download and install the latest build on your test system for testing and then update your production environment.

Let me know if you have any issues.

Regards,

Mahe

photo
1

Hi Mahe,

Thanks. It is working.

Please clarify me one more doubt.

what is the exact use of


Inherit Access Filters from client sourcein Client Source Substitution.

Thanks in Advance,

Karthik K.

photo
photo
1

Hi Karthik,

Thanks for your email.

"Inherit Access Filters from client source in Client Source Substitution"

The advantage is, if you have a Source Filter setup on the Data Source on default org, you don't need to create the same source filter again on each client org when you use client source substitution. It will reduce recreating same Access Filters for each client org for the same data source.

Please let me know if you have any more questions.

Regards,

Mahe

photo
1

Hi Mahe,

Thanks for Your reply.

THANK YOU VERY MUCH.

Regards,

Karthik K

photo
photo
1

Hi Karthik,

One last thing, we would be grateful if you could take a moment to provide your feedback by completing our Closed Request Survey.

It will take less than 15 seconds to complete and is vital in helping us to continually monitor and improve our levels of service to you.

As usual please reach out to us if there was anything else we can help you with.

Regards,

Mahe