Browse Page Columns on User Role Not Applying

Jason Kaczmarek shared this problem 20 months ago
Resolved

I just created a new user and logged-in to make sure things looked good and I realized all available Browse Page columns are showing. I only have "Name" and "Description" selected on the role though.

(v7.4.6)

Jason

Comments (4)

photo
1

Hi Jason,

Thanks for reaching out. Can you show me what Role settings you're looking at for this?

I believe these are the only configurations related to the Browse page in the Role Permissions:

/wFu3ufzd5ZnrAAAAABJRU5ErkJggg==

And that any Columns that are displayed in the Browse section, assuming the Hide Columns Option isn't checked, are set at an individual user level.

Regards,

Mike

photo
1

Mike,

The following is available at the bottom of the role setup page.

/xpgjDEO6xpCIIS8cujngAkhEgoACDEo9HPAhBBCCNFAAQAhhsTBhu7+CSEiCgAIIYQQgwP8H5k04Sp9GEvSAAAAAElFTkSuQmCC

Jason

photo
1

Hi Jason,

Thanks for pointing that out. You are right, this should work, however, this has been previously been logged as a defect. We've even tried a back-end query to force these settings and it's still not working due to the nature of the issue, so this will indeed require a dev fix.

I've gone ahead and added you to the client list of those being impacted by this behavior.

Any potential updates regarding this will be posted here. I apologize for any inconvenience this may cause.

Regards,

Mike

photo
1

Hi team - wondering if this has been fixed. We are on 8.0.5 and have the same issue - doesn't apply to the role.

photo
1

Hi James,

This has not been fixed yet, but a few more clients have reported this since this ticket's been logged so I do suspect it will be looked at soon. I've also gone ahead and added you to the client list in our internal task of those being impacted by this behavior. Any potential updates regarding this will be posted here.

Regards,

Mike

photo