Axis tick numbers not formatted

Kevin Remmert shared this problem 1 year ago
Resolved

I have some scatter charts where my Y-axis corresponds with a percentage column. Chart looks great except that the numbers on my chart-axis are showing decimal values (e.g. .01) and not the % format I specified on my column (e.g. 10%). The chart's data table is formatted correctly to show the same column with the format I desire. How can I change my axis to display the same number format as my corresponding data column?

Comments (5)

photo
1

Hi Kevin,

It sounds like you are using the percentage formatter at the report level, which is then not applied at the chart level?

I would recommend instead creating a calculated field to multiply this value * 100 and add the "%" prefix in the chart formatting menu. Generally report formatters will only apply to certain areas in the chart builder as they are a post processing effect that essentially converts this field into a string which in turn cannot be used for functions that require numeric fields such as a charts axis.

Let me know if this makes sense.

Regards,

Nathan

photo
1

Hi Nathan,

Totally makes sense what you're describing. Can you suggest where in the chart formatting menu that I can put the "%" suffix? I tried changing my number format on my calculated field to not use the percentage report formatter. Only place I found to enter a "%" suffix was onin the same place: on my calculated field in the Data tab. Changing it there had largely the same effect as specifying the percentage report formatter. That is I have no % label on the ticks. I do however have the correct magnitude I desire on my ticks by multiplying by 100.

Thanks,

Kevin

photo
1

Hi Kevin,

It seems this setting is only available on certain chart types. I was able to find it on the column chart but not have tried many others. The Auto chart does not allow this:

fd02cd02ca241ee71b7d01dd765a6cc5

Regards,

Nathan

photo
1

Autochart was the problem. Changed the chart type to Scatter and all of the missing formatting options we desired appered. Thanks a bunch Nathan! This is a big relief.

photo
1

No problem, glad you got it working!

Nathan

photo