Access Filters not on by default in reports

Vefa Gulecyuz shared this idea 4 months ago
Idea Logged

Hi Guys, when I create an access filter on a view, it is not automatically applied to existing reports.

The access filter option appears in the report builder (please see the attached ss) but I need to manually select it to activate newly created access filter.

I would like my new access filters to be automatically on existing reports. Is that possible?

Why do I need this:

I will use this in a multitenant environment using the same database. I will only have views/reports/dashboards in the default tenant and client orgs are only supposed to see the their filtered content. When I want to create a new access filter, I do not want to go through all the existing reports based on that view.

Comments (3)

photo
1

Hi Vefa,

Thanks for reaching out to support with your question.


One of our Japanese clients submitted a similar enhancement request to developers a while back -

"Ability to collectively set newly added access filters in reports"

I can add you as an affected client to this task if you'd like?

Thanks,

Eric

photo
1

Hi Eric, that would be good! Do you have an estimation on when this will be implemented?

Regards,

Vefa

photo
1

Hi Vefa,

I've gone ahead and updated the task to add you as an affected client, and asked for an update on your behalf. Will let you know what I hear. I'll attach this ticket to the task and mark this as Idea Logged in the meantime.

Thanks,

Eric