Yellowfin service JAVA_HOME used

Daniel Toste shared this question 56 days ago
Answered

Hello,

I have a client that has upgraded their Java version. We have updated the environment variables on the system to point to the new version. When running the Yellowfin service, the yellowfin-stderr log shows the Java Home and JVM version as the old Java.

The issue is that when deleting the old Java files from the PC, it would then in turn not allow the service to run as it is still looking at that older version of Java.

We also tested updating the JRE_HOME value in the catalina and service bat files, added our own JAVA_HOME variable in those files, and ensured that the Tomcatw.exe was looking at the correct dll file. Even after making all of these changes and restarting the machine, the stderr log still shows that the service is pointing to the older Java version.

Why is the service not taking on the environment variable? What other configurations would need to be updated to make sure that the Yellowfin runs on the latest Java installed?

I should note that there is another Tomcat service for a separate application running on the same machine and that has taken on the newer Java version.

Thank you,

Daniel

Comments (9)

photo
1

Hi Daniel,

If you're running Yellowfin as a Windows service and you've updated the Tomcat Java options as per this screen:

/2b331ba0c2be33cefe8ec8c9d97c5da1

I would uninstall the Yellowfin service and then reinstall it. You can do that by following the commands in this document.

If that doesn't work and Yellowfin's catalina.bat file is set correctly, I would try running startup.bat just to double check whether that route works instead.

If that still fails, please could you send over the stderr.log file.

Kind regards,

Chris

photo
1

Hi Chris,

Thank you for the information. Just to clarify before I make this suggestion to my client, when you say update the Java Options, are you solely referring to the Java Virtual Machine "dll" file portion? Or are there other -D options that would exist in the Java Option text box on this tab as well?

Thank you,

Daniel

photo
1

Hi Daniel,

Yep, that should be the only option that needs changing. However, if you uninstall and reinstall the service, Tomcat will prioritise the JRE_HOME variable set in the service.bat file in the Yellowfin/bin folder over the Windows Environment Variable, as per my screenshots below where I initially set JDK 14 as the Java path environment variable, but reinstalled the yellowfin service where service.bat has JDK 11.

/ca7859aeff617fa44887762b428e043e

/7b61c43af23fd8664ec26a0554a5d7e0

/c211b983046ff9901d4d58e65ebfb841

I hope that's clearer! Let me know if you're still having issues.

Kind regards,

Chris

photo
1

Apologies, just to be clear, I do mean the Java Virtual Machine .dll path, and not any of the lines in the Java Options text box.

photo
1

Thank you for the clarification. We had manually updated the server.bat but I will ask them to remove then reinstall the service.

I will update this ticket once I hear back from the client on the success of the steps.

Thanks!

photo
1

No problem, do let me know how it goes.

Kind regards,

Chris

photo
1

Hi Daniel,

Hope you're doing well.

Just a quick follow up, did you hear back from your client on whether the recommended steps were succesful?

Kind regards,

Chris

photo
1

Hi Chris,

I reached out to the client yesterday for an update, but have not heard anything back. I am not sure if they have tested you suggestion yet.

I think we are okay to close this ticket for now and if I hear back from them stating the issue persists after removing and reinstalling the service, I will reach out again.

Thank you for your help!

photo
1

Hi Daniel,

Hope you had a good weekend.

Thanks for letting me know. Closing this one off for now!

Kind regards,

Chris