View Data Shows More Than 20 Rows When Using Amazon Redshift Connector

Whit shared this problem 3 years ago
Resolved

Hi all,


On Amazon Redshift data sources, when you enter a Yellowfin View and click 'View Data' on a table (not the whole view) the content is not being restricted to 20 rows. The resultant data appears to be every row in the table. Do you mind trying to repro? I am not able to repro this on a mysql connected data source.


Thanks,


Whit

Comments (5)

photo
1

Hello Whit. We are testing a few things and will have something to you shortly. Cheers

photo
1

Hi Whit,


Thanks for your patience with this one.


I just tested this with Yellowfin on AWS (using 7.2) and when I viewed my table data it correctly restricted the amount of rows returned (20).


/JqE3WahDhpAAAAAElFTkSuQmCC


Could you let us know which version/build of Yellowfin you are running and maybe send in a screenshot or two demonstrating what you are experiencing so I can test this using your environment details?


I look forward to hearing back!


Kind Regards,


Dustin

photo
1

Hi Dustin,


I am sorry, I should have made note that we are on the dec build of 7.1. I have attached a screenshot showing what I am seeing--row count says 20 but more than 20 rows are showing. I have also attached some of the data source settings. Also of note, this is a non-writable, secure data source that is using Source Filters. I am not sure if any of that matters, but just in case. Let me know what else I can provide for you.


Thanks!


-Whit

photo
1

Hey Whit,


Thanks for the additional info. I just wanted to let you know I'm testing with your build. I'll have some more info to pass along later this afternoon.


Kind Regards,


Dustin

photo
1

Thanks, Dustin!

photo
photo
1

Hi Whit,


Good news on this one... I was able to replicate what you are experiencing using your version/build of Yellowfin (7.1 December). However, this has since been fixed in more recent builds (I tested 7.1 February):


/8X24T5ua3ua3QAAAAASUVORK5CYII=


So if you upgrade, this problem should no longer be present. Is it possible for you to upgrade Yellowfin to a more recent build and see if that fixes what you are seeing?


Anyway, let me know what you think. I look forward to hearing back!


Kind Regards,


Dustin