Vertical column bars not displayed (where line chart works)

Sam shared this problem 2 months ago
Resolved

Running YF 9.3.1. I have a simple vertical column chart that worked previously, but if I edit it (to sort differently), the bars vanish. Trying to recreate it anew, the auto-chart type of line chart displays, but when switched to vertical column there are no bars.

Here's the working line chart:

/5a2f5835acae5d34c0bf0c549b1538a1

Then when I click "vertical column" chart type, it's blank:

/93e42b550e847df0309bbd4141858758

Any ideas or advice?

Comments (8)

photo
1

Hi Sam,

Thanks for reaching out. I'm unable to replicate this behavior:

/16bf584ad7ac9bceb73b8722c8812495

Can you please re-replicate by getting to the point where you're loading the charts and not seeing any output, take note of that timestamp, then subsequently provide a compressed copy of your entire logs folder, located at <YellowfinInstall>/appserver/logs, along with said timestamp, so we can investigate further? If the logs file is too large you can upload it to our FTP site here: https://ftp.yellowfin.bi/

Thanks,

Mike

photo
1

I just uploaded the .zip of my full logs folder, see the timestamp of 12:53-12:54 (up until activity ends at 12:54) - it looks like the only file that changed yesterday was localhost_access_log.2021-02-24.txt.

Thinking of possible contributing factors to this behavior:

  • The data source is a .csv
  • The column being plotted starts off as a text value because it's a mix of numerics and text values like "A+"
  • Then it's used to create a numeric variable that is the one plotted, via the Freehand SQL command
    CAST("Finance KPI Data.csv"."f164231value" AS NUMERIC(10,10))

photo
1

Hi Sam,

I meant to look at this further today but I had something come up. I will set up a use case that more closely mirrors yours first thing tomorrow and give you another update.

Regards,

Mike

photo
1

Hi Sam,

I imported a CSV data set with varchar values, but I'm unsure how you're able to cast varchar data as numeric. I tried in MySQL and SQL Server and both give errors. SQL Server indicates that you can't cast varchar values to numeric and in MySQL I can cast to decimal but it changes everything to 0's or 1's and isn't recognized as a Metric field:

/d705f6c018d91503471d8ff54034e384

Original data:

/5555f898facccef274e10a12d72df869

What RDBMS did you import the CSV into where you're subsequently executing the CAST statement against?

Regards,

Mike

photo
1

Thanks for your continued investigation. The .csv was imported into Microsoft SQL Server 14.00.3370.

It looks like this in the CSV view (see the rightmost column):

/f73ea6856a846508e7030dede45634ac

Maybe what makes it work is that on the Data view, I have a filter for Metric Equal To "Retirement Plan Funding". Which only has numeric values of Value, that filtering excludes the A+ text values. Does your CAST() succeed if you add that filter to another column?

Here's the cast:

/54b171e11e05c382cac958c9d877f412

And then the result:

/1f74291cc9c6c0d04bcec885ac764dc9

photo
1

Hi Sam,

I wasn't able to get this replicated in the same exact way, what I did instead was use a CASE statement to make non numeric values null, then the rest would be returned as numbers:

/b3e0c856d48c3e65f965bb487aa8256e

This was my initial result in the Charts... a blank auto-chart:

/08bddf9290f90419dd61f72251301f91

And if I switched to Column Chart, an actual error appeared:

/3304b472586bdd91d343bcf7b4a579ce

Turns out though, that YF doesn't like this data unaggregated.

If I set my data to a Sum Aggregation (Note: this has to be done in the Data section, not the Charts section):

/3939efba4455a4562b0174584f4a411e

/d55a5aa841c90d466efaa631f5d27953

You can see data is now generated:

/18c57411dc7bc165e0e6e56b82c5ddec

/0d5f024c4e5cedf65816403af639eb99

As you can see, my number data itself also doesn't change when aggregating in this case, so I'm thinking you should be able to do this as well.

As such, can you attempt adding an aggregation to your Metric in the Data section and re-adding it in the Charts section and seeing if the Chart then generates?

Please let me know how goes. If this doesn't work please let me know if the behavior changes at all - something different in logs, an error message in the UI, etc..

Thanks,

Mike

photo
1

I appear to have solved this, we were barking up the wrong tree. The column chart appears completely blank as seen in the screenshot I originally posted. But if I mouseover a year, I see it highlight:

/885cf0c547bdc88862e9d49966c04077Revealing that there are columns there, they're just so thin they're invisible. It turns out the Date variable has defaulted to formatting of Units = Milliseconds. When I switch that to Units = Year, I get the chart as I expected it.

I'll change the variable settings on my end but in case this affects others, I'd suggest a feature that if there are columns present, they not be able to be so thin that they're invisible - especially by default.

Thanks for diving into this - this ticket can be closed.

photo
1

Hi Sam,

That's bizarre. I have to say that's something I've not seen before, but thanks for letting us know what happened here! I'll certainly keep this in mind for the future.

I'll indeed go ahead and close this out now that this is sorted, but please don't hesitate to reach out with any other questions or concerns.

Regards,

Mike