Unable to delete or edit report

Shirin Fardi Butler shared this problem 2 years ago
Resolved

I have a report and view in 7.1 that I exported and imported into 7.2, however I'm unable to edit or delete the report imported. I have accessed the views imported (the report has sub queries) and have enabled security on the views however I am still unable to edit. I am able to access and edit other reports but not one in particular. Is there something else I should be looking at to be able to edit?

Comments (9)

photo
2

Hi Shirin,


Thank you for getting in touch. Typically when this occurs the solution is in the permission settings within Yellowfin (data source> view> content folder> report). If your user has the proper access to each of these levels then we will need to look into alternative solutions, mostly revolving around finding this report and its permissions within the configuration database.


However it is worth noting that editing the configuration database is not officially supported and can result in lost content. (Always backup your config db). As this is not officially supported, I am hesitant to suggest anything specific until we have drained all possible solutions within the program.


For now can you ensure that your user has full delete privileges at each of the levels specified above? (may be worth removing then re-adding your user to the allowed access list as well).


Regards,

Nathan

photo
1

Thank you for the feedback Nathan. I discovered I copied the datasource and I think that may have been where I went wrong. I deleted the duplicate data source and broke up the process into two steps first bringing in and replacing the views and then bringing in my new report and all is now working.

photo
1

Hi Shirin,


Glad to hear you got it working!


Regards,

Nathan

photo
1

All good.

photo
photo
1

Hi Shirin,


I will need to do some testing to know for sure but typically, the permissions of your imported content should match that of the new environment. Are you able to get reports to upload consistently now that you have the permissions set up?


Regards,

Nathan

photo
1

I'm not exactly sure what happened. I imported a view and then then imported the report, accessed report, couldn't edit, went and updated permission on view. Somewhere along the line it looks like I made a dup view, once I cleaned everything up I'm now able to edit.

photo
photo
1

Hi,


We are having what looks like a similar issue. We had a report that when we made a copy of it, it threw a permissions error (attached) and now we can't edit or delete the copy. We can only open them (see second attachment), despite using admin credentials.


We were able to fix the source report by editing then saving with no changes, so new copies can be made properly now, but we can't seem to do anything about the previously broken copies.


How can we remove them?

photo
1

Hi Bogdan,

My apologies for the delay here. Can you please send me your entire logs folder after replicating this error?

YourYFInstall/appserver/logs

Regards,

Nathan

photo
1

Hi Nathan,

Logs attached. I created the 'stuck' reports between 11:40 and 12:10 on Jul 13th.

I would have right clicked on those reports and attempted to delete them in that time too.

photo