The issue with Time Series

Loc Ngo shared this problem 5 years ago

When moving to use Time Series. I found these issues bellow:

- The drill through is stopped working

- The last x-axis labels is cropped

And a question more is Can I able to set Category Spacing when Time Series is on?. I found that I can do when Time Series is off

Replies (3)


Hi Loc,

Thanks for reaching out.

Drill Capabilities vary by chart. If you reference our Wiki article "Drill Capability on Charts", you'll see that drilling is not supported with Time Series charts: There was an Idea submitted to allow Drill Through on Time Series charts, but it has been marked as Not Planned by the dev team. I've added a comment to this community item to log your support for this Idea, should it be the case this is ever re-considered for future development, which having more requests could plausibly aid in doing.

In terms of the other two points, the x-axis labels (potentially) getting cut-off is an already logged defect. Unfortunately, the issue with both spacing and the x-axis labels, is that this is actually related to the charting library (JFree) we use. The way it works is that, when first creating your chart, it looks at your data and does it's best to draw the charting area to ensure it all fits. However it does not always check every single label (to save on performance time).

This is not something likely to be fixed any time soon as there is no straight forward way to get around this with the library. While there may technically be ways for us to create our own functions, it was decided this was far too large a time-sink of dev time for this, and for how infrequently we see this issue, it's felt that the effort vs result just does not line up.

Beyond this, there are actually a few workarounds to mitigate this behavior.

We believe the following suggestions should get around this with little impact to the end user, and in some cases may actually improve the overall look:

-Rotating the label axis.This is also how excel behaves, if the labels are too long, it switches it to 90 degrees.

-Use a shorter time/date format

From the chart example you've provided, you're displaying the values as mmm - yyyy.

If you displayed it as mm/yyyy or better yet, mm/yy, then the values would fit.

At the moment this is all controlled by the column format, so the table will also display in this format.

-You can change the Margin settings from its default. Here is my built report at default of '1':


I then went into the date columns, Axis Settings > Style option and set Margin to '3', and now nothing is cut-off:


-Also in the Horizontal Axis Settings under Style, you can switch Label Font to Custom and choose a smaller font size.

As you can see, there are several options to get around this behavior.

That said, addressing this hasn't been completely written off. It is stated that this is still something to revisit in the future with chart library changes, but it's a low priority item.

Please let me know if you have any further questions on this.




Hi Mike,

Thanks for your support.


Hi Loc,

You're welcome. It seems this addressed your questions so I'll go ahead and mark this as Resolved. If you have any further questions please don't hesitate to reach out.



Leave a Comment
Attach a file