Sub queries disappear

Peter Lalor shared this problem 2 months ago
Defect Fixed

Hi we have just upgraded to the latest 7.35+ build and now subqueries seem to disappear between defining them and configuring suquery filters, I create a subquery, add a filter, save the sub query and go back to my master query. The sub query is visible in the panel at the top left of the screen. I then click on Advanced Settings to configure filters and the filter for the subquery is gone and when I go back to the main query the subquery is also gone! Ive done this using a number of different types of subqueries in a numbe of different views - all with the same results. Help!

Comments (13)

photo
1

Sorry, just realised Ive logged this under my old id plalor@superiq.com.au, should be under my newer id plalor@moneybrilliant.com.au

photo
1

Hi Peter,

I've got the same build as you and have been trying to replicate the issue you describe but so far unfortunately I've not been able to. (I've attached a short video of my efforts). So I'm wondering if you could send across your log files (making sure that they cover the time frame in which you experienced the sub-query issue), and also if you could check your browser's console for any javascript errors.

thanks,

David

photo
1

Hi Dave, I did a bit more testing and I too can build append sub queries. Would you mind checking to see if minus and intersect queries work with your instance?

photo
photo
1

Hi Peter,

wow, that's a bad bug! Yes indeed, Minus and Intersect queries are broken.

A product defect has been raised (YFN-7769) and its priority has been set as HIGHEST which, as the name implies, means that there is none higher, so it should be pretty near the top of the developers' work list.

Thanks for alerting us to this bug, and apologies for the inconvenience caused by it.


regards,

David

photo
1

Hi guys, do you have an ETA for a new build where this bug is fixed - or a sensible work around?

photo
1

Hi Peter,

the defect has its Priority set as HIGHEST, and its Severity set as CRITICAL, so as you can imagine, that gets it pretty near the top of the developers' queue which means it will definitely be fixed for the next build (November).

regards,

David

photo
1

Hi. Thanks for the response.  Wow - Im surprised it wont be fixed until the next scheduled release. This is a pretty major issue that is severely impacting our use of application.

Regards,

Peter Lalor

CEO

phone  0401 716 194

email  plalor@moneybrilliant.com.au

web  www.moneybrilliant.com.au

logo_email

Note: The information transmitted in this message is intended only for the person or entity to whom (or which) it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

On 5 October 2017 at 12:18, Yellowfin Support <support@yellowfin.bi> wrote:

photo
1

Hi guys, any chance of an update on this? We cant wait until a November release for a fix to this and will have to find a different way of delivering key insights our business and customers expected to be delivered during the last week (that rely on intersect queries).

photo
1

Hi Peter,

good news! Because this is a pretty major issue there will be a fix done this week and a special interim build created with the fix in it also this week. We'll let you know as soon as it's ready.

regards,

David

photo
1

Thanks Dave. I look forward to receiving the update.

Regards,

Peter Lalor

CEO

phone  0401 716 194

email  plalor@moneybrilliant.com.au

web  www.moneybrilliant.com.au

logo_email

Note: The information transmitted in this message is intended only for the person or entity to whom (or which) it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

On 9 October 2017 at 10:42, Yellowfin Support <support@yellowfin.bi> wrote:

photo
1

Hi Dave, downloaded, installed and working! All seems good. Thank you.

photo
1

Hi Peter,

that's great news, thanks for letting us know!

And apologies again for the inconvenience caused by the bug.

regards,

David