SQL Data Connection Keeps Asking for Password

Lawrence Brown shared this question 19 months ago
Answered

Hi,

One of my clients has a strange issue in that they regularly need to re-enter a SQL login password for a data connection. It sometimes take a long time for the Data Source to save but it does work, the problem seems to be that it isn't storing the password.

As far as they can tell nothing is changing on the SQL Server side.

Any ideas on what this could be.

Thanks in advance,

Lawrence

Comments (5)

photo
1

Hi Lawrence,

Thanks for your email.

Yes, it is strange that they need to regularly re-enter a SQL login password for data connection.

I am just wondering when are they needing to type in the password? Can you provide me a quick video or a screenshot of the place where client is typing in the password?

We have never seen this issue before, if you can provide more information that will be helpful.

In Yellowfin configuration database the Datasource passwords are saved in ReportViewSource table, please check that table to see if the password is saved in it or not. It will be in the encrypted format.

Please let me know if you have any issues.

Regards,

Mahesh

photo
1

Hi Lawrence,

as well as that, some further information is that over here we created a Yellowfin data source for an SQL Server database, then created a view and a report based on it.

Then we deleted the password from the Yellowfin table ReportViewSource, and then ran the report (after restarting Yellowfin) and we did not get a prompt asking us for the password. Instead we just got an error "Error running report. A connection could not be established to the source database"


regards,

David

photo
1

Hi Mahesh and Dave,

So the client changed the SQL password and updated the Data Source on Yellowfin with the new password and it now seems fine.

They and I are happy to leave it as that but if you guys want any information from the server to investigate then I can get it for you?

Defo a strange one, I've never seen it before either.

Regards,

Lawrence

photo
1

Hi Lawrence,

Thanks for your reply. Glad it got resolved after changing the password.

If it is working now, we will not disturb it, keep monitoring it for couple of days, and if nothing crazy happens then we will probably close this ticket.

Please let us know if we can assist you with anything else.

Regards,

Mahesh

photo
1

Hi Lawrence,

Hope you are doing well.

I am marking this ticket as answered.

Let me know if you have any questions.

Regards,

Mahesh