Single Sign-on option "disablesidenav=true" not working

Stephen Van Rooyen shared this problem 8 months ago
Defect Logged

Hi Guys,


I'm using Single Sign-on, and trying to disable/hide the left side nav using the parameter disablesidenav=true but my side nav is still being displayed.

I've tried setting it via the setParameters() method as well as via the URL both methods does not seem to work.

Tested it on v7.4 build 20180515


Regards,

Stephen

Comments (9)

photo
1

Hi Steve,

thanks for your jsp! However, I don't know what is going here, because in my 7.4 20180515 your jsp is working perfectly!

I've attached a video that demonstrates the Left Side Nav has been disabled after running your jsp.

For starters, could you please send across a video showing the issue in your YF?

Then I'm wondering if there is something about the user, or the previous system settings that maybe is causing that option to fail. So with that in mind, could you please try with different users and also with different system settings (I mean Admin->Configuration->System->General Settings->Left Side Navigation/Toolbar Navigation) and see if the outcome is the same.

Also, could you please try using the alternative login session option called "hidesidenav" instead of "disablesidenav" and see if that is any better for you? (they both seem to work for me)

thanks,

David

photo
1

Hi Dave,


Hopefully this will clarify, when viewing a report or a dashboard the side nav bar (not the menu) is still visible


f4b14f9fdc9144960a6466e80f6db6e3

I've tried the hidesidenav option as well and i get the same results.


Regards,

Stephen

photo
1

Thanks Steve, now I've got it!

I actually don't know what those items that you've circled are called, but I do know that according to the wiki, they are not the side navigation:

http://wiki.yellowfin.com.au/display/USER74/Navigation#Navigation-NavigationStyles

When I ran your jsp it disabled the side navigation mentioned in the above wiki article (the expandable area with the menu items going down the left side).

Does this make sense?

regards,

David

photo
1

Hi Dave,

I think I may be confusing it with the Left Side Nav, eg. When you set your filter to use the Left Side Nav it appears on that bar.


cf79ce19eabef91ae64fadf63721ad11

Added to that, it has also been around long before the menu was vertical (back when it was still on the toolbar).

c0b2a646516258103a3026d6eb5eba16


That being said, is there a setting to disble the Left Side Nav (as I know it the bar circle in the picture).


Regards,

Stephen

photo
1

Hi Dave,


Just some additional info, the disablesidenav option (as you explained, disabling the hamburger menu)

only seems to work when the entry point is the browse screen (entry=BROWSE) when you viewing a dashboard the hamburger menu is still visible.


Regards,

Stephen

photo
1

Hi Steve,

to hide the left nav side bar that you circled I think you will have to use the CustomCSS feature:

/z9TjWL0loFZQgAAAABJRU5ErkJgggA=

Please give that a try and let me know how it goes.

regards,

David

photo
1

Hi Steve,

good news for you and bad news for me.....you were RIGHT and I was WRONG! One of our leading consultants tells me that the vertical bar on the left side that you circled is indeed called the side navigation and in fact it should be hidden if you use the DISABLESIDENAV or HIDESIDENAV login session options.

So I apologise for my mistake (although I hope you can understand why I thought so, after reading that wiki link I previously sent you), and now I have raised a product defect (YFN-11475) so that it gets fixed.

I guess this means that my previous response in which I suggested using Custom CSS is now not a solution, but instead, it is just a workaround until defect YFN-11475 gets fixed.

regards,

David

photo
1

Hi Dave,


Totally understandable, I dont blame you at all.

You even had me doubting myself for a while there.

I would blame the wiki for the confusion, but even within Yellowfin it refers to the menu as the left side nav21dfa3e00dd1bdbfbcf42acdbf3764e3


Thanks for logging the defect, I will in the interim be using your suggested workaround using the CustomCSS.


Regards,

Stephen

photo
1

thanks for your understanding - you are a scholar and a gentleman I'm sure!

thanks,

David