Shrink To Fit Sets Dimensions to 0 x 0

Lex Clay shared this problem 9 months ago
Defect Fixed

Hi Guys,

Shrink To Fit doesn't seem to work on subtabs in 9.4.2. Seems that this was also the case in 9.3.0. Not sure if that helps any.

/66aeaf5eedfee751588d127ac7a789b2

Comments (9)

photo
1

Hey Lex,

I hope you are doing well!


I have replicated this in 9.4.2 by creating a canvas dashboard > Publishing > Editing > & then selecting 'Shrink to fit'

Though creating the Dashboard from scratch would not replicate, only when editing the published version.


Was this the same for you?

Below is my replication :) -


When first creating my dashboard I set the Width & Height manually -

b88ecd6e421e0bf2547ebd61ebe9806a


I then selected Shrink to Fit & this appeared to work well -

c67f3a61b6172a1d1176351f74de711d


I then published > selected to edit > selected Shrink to Fit again and then replicated the issue -

b104f6fdfdfa884196fe80d3723eb947


And here is my info.jsp for good measure -

eb76f5ba517b5ce5c34dde841a6b5fdf


As I have replicated, I have already created the Defect task with the devs - but if you can replicate the defect before publishing editing the dashboard again, let me know and I will test it again your way and update the dev task


I have added the task ID to this ticket - but before I mark as 'Defect Logged' I will wait for your confirmation :)


I hope you have a lovely weekend, Lex !

Best Wishes,

Lesley

photo
1

Hi Lesley,

You're working late aren't you?

I haven't tried before publishing the dashboard tbh. I only tried it on dashboards that have already been published at least once...although it does give me an idea for a workaround, I'll try copying the dashboard and seeing if I get the same behaviour, if not, that could be a workaround for now.

photo
1

Oh just a little bit... but I would rather get an answer out to you than leave you thinking about it all weekend!

Great, let me know when you try that out, if it works or not :)


Best Wishes,

Lesley

photo
1

Cheers Lesley, appreciate it. Will let you know. Have a good weekend.

photo
1

Hi Lesley,

Ok so making a copy of the dashboard doesn't make any difference, it still goes to 0 x 0 on shrink to fit

photo
1

Hey Lex,

As an alternative workaround - could you manually enter the dimensions?


This is the copied version -

c9b45b5fa5b7be37fc7bdd9b7c2068c3


bb3cf8807f588f4a8acf46d4906090e0


Then I entered dimensions manually -

2abc55af62c0bca239ab24bc454a5d24


And this is the result after publishing again -

bcb4c71b10bfee4dc32741abe53ec161


Best Wishes,

Lesley

photo
1

Oh yeah, manually entering the dimensions has never been a problem, I did that as soon as I saw shrink to fit was having a fit.

photo
1

In that case, I will mark this ticket as 'Defect Logged' for now - but let me know if you have any more thoughts on this!

I will update you when there is progress on the task.


Have a great weekend! :)

Best Wishes,

Lesley

photo
2

Cheers Lesley...now stop working and get on with your weekend!... have a good one.

photo
photo
1

Hey Lex,

I hope you have been well & had a lovely weekend :)


Some good news - version 9.6 is now available for download - and this issue has been resolved in 9.6


I will go ahead and mark this ticket as fixed, but if you have any further questions, let me know !


Best Wishes,

Lesley