Show progress incidator at the top of the report

JeRoen shared this idea 12 months ago
Completed

When I add a report to a dashboard and run it, the progress indicator is shown vertically centered in the space the report has on the dashboard.

For a specific report I have set the space on the dashboard to be very large (only one report in this dashboard) because if I don't do that I will get double scrollbars in the dashboard.

So the scrollbar is now limited to only one (instead of 2) but the progress indicator is not visible anymore without scrolling. Resulting in confusion by the end-users.

When the progress indicator is shown at the top of the report page this will always be visible.

Regards,

JeRoen

Comments (7)

photo
1

Hi JeRoen,

I hope all is well,

In order for me to push this with our development team as an enhancement, would it be possible to send across some examples of the idea that you are wanting?

NOTE: Please be careful with sensitive data in these images, as this idea is public for all members to see.

Regards,

Mark

photo
1

Hello Mark,

Sorry for my late response. Images will get tricky as the problem will by definition do not fit on the screen (that is exactly the problem :-).

Just create a dashboard with only one report on it and when you make it rather high you won't see the progress indicator when you run the report. Normally this is not a problem as the reports will run within a few seconds but the report I am having is running in just under 10 seconds.

Regards,

JeRoen

photo
1

Hi JeRoen,

Thank you for getting back to me. I have gone ahead and created a dashboard and added 1 report to this that I know takes longer than 5 seconds to run...

However I am not 100% sure where the issue lies. Would it be with the loading indicator that you see from my below image:

49f23d4389c3bfd9339337359cbdceac

I have made this report fairly large (height) on the dashboard. Does one need to make any adjustments?

Regards,

Mark

photo
1

Hello Mark,

Sorry it took so long to answer.

It is indeed the issue I have been having. The progress indicator is always shown in the middle of the report loading. When that report is very large it is not shown but you have to scroll down.

We resized the report to a height less high so the issue is not there anymore. So no problem for us at the moment.

Regards,

JeRoen

photo
1

Hi JeRoen,

Thank you for the update on this... With regards to your workaround "We resized the report to a height less high so the issue is not there anymore. So no problem for us at the moment" Are we good to mark this idea ticket as Completed? or would you like me to further investigate?

Regards,

Mark

photo
1

Hello Mark,

No problem to mark the ticket as completed.

Regard,

JeRoen

photo
1

Hi JeRoen,

Thank you for confirming, have a great week ahead.

Regards,

Mark