resetting the drilldown on dashboard portlet

Matt Young shared this idea 22 months ago
Idea Logged

I have a simple drilldown report I'm using in a dashboard portlet. The single filter on the report is getting updated but the drilldown does not reset. How can I set this to reset when the dashboard reloads? I've tried the filter options but no success.

Comments (5)

photo
1

Hi Matt,

Once you have drilled down 1 or more levels then an "Up" and also a "Reset" link should appear just to the left of the report maximise button as shown below:

1) top level of drill down report:

/UGWy2RML7kgAAAAASUVORK5CYII=


2) "Europe" was clicked, and then "Up" and "Reset" links appear:


/MguKC6RFQEAAACXyIqoKGRFAAAAwBWyIioKWREAAABwhayIikJWBAAAAFwhK6KikBUBAAAAV8iKqChkRQAAAMAVsiIqClkRAAAAcIWsiIpCVgQAAABcmQIqTP6+TWRFAAAAAIAZWREAAAAAYEZWBAAAAACYkRUBAAAAAGZkRQAAAACAGVkRAAAAAGBGVgQAAAAAmJEVAQAAAABmZEUAAAAAgBlZEQAAAABgRlYEAAAAAJjNzMz8H3ej+7udi6rBAAAAAElFTkSuQmCC

Please let me know if those links are working for you or not.

regards,

David

photo
1

Yes, sorry for not being more clear. The drill down functionality works in the portlet, as well as the up and reset links you describe. However, when the dashboard filter changes (choosing an unrelated company), I would like all of my portlet reports to reset to default settings. The drill down selection remains applied, and I currently have to manually select the reset to return to the top level. Using your example - If I first viewed the report and selected Europe, but then changed my filter to a selection with no data in Europe, I'd get "No results returned".

ba4b03653cf3db28d8edf185fbed26a0

Thanks,

Matt

photo
1

Hi Matt,

sorry for misunderstanding you, and thanks for the extra information - I think I've got it now, you are asking for the ability to configure a dashboard tab such that any change in a filter will also cause the drill-down hierarchy to be reset to the top level.

The short answer is this can't be done at the moment, and so I'll turn this Question into an Idea if you would like, just let me know.

And the slightly longer answer is that I was playing around with my dashboard and sort of found a workaround, although I suspect you won't like it because it's a bit of a dirty hack:

1) In the Dashboard tab's Analytic setup, configure your Drill-Down field to be displayed as a filter:

/8PJ+RIYgwNZ18AAAAASUVORK5CYII=

You'll find that if you leave this new Drill Down filter empty, the Drill Down level will always jump back to the top level when you click the "Go" button because in effect you are requesting for all values to be displayed.

2) It might make things less confusing for the user if the Drill Down filter's title isn't displayed - then they won't know what it is there for and will hopefully leave it alone! And you can do this by changing the filter's title to the space character (<ALT>+<255>)

/jfFoplkfxaUAAAAASUVORK5CYII=

So, as you can see, it's a bit of a dirty hack, but I mention it just in case it might meet your reporting requirements.

regards,

David

photo
1

Well, I tried the workaround, but it didn't work for my dashboard. I can definitely see this causing some confusion with end users, so please mark this as an Idea so this may hopefully become an option in the future.

photo
2

OK Matt, I have moved this Question to an Idea as requested.

regards,

David

photo
1

Thank you!

photo