Reference code colours bug

Matt King shared this problem 2 months ago
Defect Logged

Hi,


I am using several sets of reference codes to determine the colours for several different stacked bar charts. If two sets of reference codes contains the same code/description, then the colours are applied randomly.


Example:


I am using the reference codes in Picture 1 to colour the chart in Picture 2. As you can see, the "Acquiring" portion of the chart should be blue but is coming out yellow. After hunting around, I found that the ENTIRELY SEPARATE reference code in Picture 3 also contains the code/description "Acquiring" with the associated colour being yellow.


Could you please explain how/why this is happening and how to avoid it - currently I am having to manually set the colour of each series across all my charts because I have no idea if/when a similar problem will occur.


Matt

Comments (5)

photo
1

Hi Matt,

Thanks for reaching out to support with your issue.

Initially, I was thinking this could be related to how the reference code is applied in the report - for example I made a new reference code and was able to get it applied successfully in a related report.


788a0aa73e7c255839b21de944a324cb


I had to create a second column (demographic -demo2) in the data step to apply a different reference code to the same field.

49cf45d32900844f377d673b8dfd6699

ac16557ef05c513a0f0cd224cdefb51d

The issue I'm having, is that I'm seemingly unable to apply colors by reference code in the "layered" chart configuration -


6f9321978f9cffe6d45b80bf48d066d9

It looks like as of current versions, the coloring would need to be applied at the chart settings level for this particular type of chart.


Perhaps this is not the case though - could you provide additional details for replication if our chart or data styles differ?


Thanks,


Eric

photo
1

Hi Eric,


I am not applying multiple reference codes to the same field - they are being applied to different fields, from different Yellowfin views. The only commonality they share is the Code/Description for some members of the Reference Code set.


Additionally, the chart I am using is of the stacked horizontal bar type with a single series - see picture below.


Matt

photo
1

Hi Matt,

Thanks for the clarification here. I've been able to replicate this, it looks to be possibly defective behavior. I have in turn created a developer request to look into the issue. I have attached this ticket to the task; updates to the task will be provided here as they are available. I will in turn mark this as Defect Logged for now, feel welcome to reply here with further related inquiries.

Thanks,

Eric

photo
1

Hi Matt,

Good news - a fix for this issue has been implemented by developers, and should be included with upcoming releases. I will keep this marked as Defect logged in the meantime, and continue to provide updates here.

Thanks,

Eric

photo
1

Hi Matt,

Just wanted to provide an update here- this fix was included in recent release 7.4.12. However, it looks like you are looking for this in 8.0 versions, correct? In which case, it should be included with 8.0.4, which should be out by year end.

Thanks,

Eric