Receiving a wrong thousand separator over the API in yellowfin

Amir Shaikh shared this problem 2 months ago
Resolved

Hi Experts,

Customer embedded reports from Smart Reporting over the .../yf/JsAPI;... API.

In this API we receive the content with a different thousand separator as we have set for reports on Smart Reporting.


Embedded Version

1,234

Example for one cell of receiving from server:

<td class=\"rpt134437 rpt134437f56\" title=\"1,437.00\">1,437.00<\/td>


On Smart Reporting

1'234

Example for one cell of receiving from server:

<td class=\"rpt134437 rpt134437f56\" title=\"1'440.00\">1'440.00<\/td>


We using the API which returns JavaScript in order to execute on our page.


From code perspective we include scripts pointing to the Smart reporting API:


<Script url={`${Config.get('camundaProxy')}/engine-extensions/yf/JsAPI`} /> <Script url={`${Config.get('camundaProxy')}/engine-extensions/yf/JsAPI?api=reports`} /> <Script url={`${Config.get('camundaProxy')}/engine-extensions/yf/JsAPI?api=dash`} />


We also create container (HTML element) on our side which is used by your script for rendering reports.

In Smart reporting, the thousand separator is already set to comma (,), please check the screenshot attached.

So basically,

1. If the report is opened in SmartReporting UI, the separator is displayed according to the configuration.

2. If the report gets embedded via API, the separator is not displayed according to the applied configuration.

Appreciate your help on this.

Information:

Smart Reporting : 9.1.03.001

Midtier: 9.1.03.001 201711171337

Comments (42)

photo
1

Hi Amir,

Thanks for reaching out. Can you provide a copy of the actual web service being used? If this is not possible, can you at least point me to the actual function being called in the web service so I can reference it in our documentation and attempt replication on my end?

Thanks,

Mike

photo
1

Hi Mike,

Thank you for your response on this.

I will try to get this requested details from customer and update this thread accordingly.

Thanks,

Amir

photo
1

Hi Amir,

Thanks. I look forward to your update.

Regards,

Mike

photo
1

Hi Mike,

Please find the customer response.

Our web service call is following:


Embedded Request of the webservice : .../yf/JsAPI;2431cf9d-ed4d-418f-96ee-71da49168d90=f09c272a-331f-4c87-994d-a1d0d6f745de?api=reports&cmd=loadReport&reqId=1&version=2.1&reportId=134437&height=252&width=1232&display=chart&reload=true&u=336833330


By the embedded version we receive the wrong separator.


For comparison in the Smart reporting the separator is correct:

Smart Reporting Request: .../MIReportOutputAjax.i4;2431cf9d-ed4d-418f-96ee-71da49168d90=0f39484a-a2cb-43a3-a398-1478788273fd?action=loadOutputModel&key=134437&dpr=2&_=1572447700215

If it is not clear, we can have a quick webex session to reproduce the issue.


Thanks,

Amir

photo
1

Hi Amir,

Thanks for your response. This appears to be the report request itself, but what I was looking for was the actual API file. What I'm mostly curious of is the user who's calling the web service.

For example, here's the login credentials for one of my working web services:

/9012abd10302329ea5cdb0dd5e98a299

I may be logged in as say michael.sheehan@com.com, but if my web service is inputting credentials for another user and that user has a different separator configured, for example, then the returned results will be different. So can you check on the user found in the actual web service .jsp file then go into that user accounts' Text Format > Thousand Separator details to see if it's configured as expected/desired there?

If this proves unfruitful, I still think it'd be beneficial to take a look at the .jsp file itself being used for the web service, but if this is not possible I'm happy to set up a call so you can demonstrate the behavior you're experiencing.

Regards,

Mike

photo
1

Hi Mike,

We have received below response from our customer:

Thanks for your answer from Yellowfin team. I'm not sure, what the Yellowfin team exactly mean with the web service .jsp file. If there mean the settings in our config files for the connection to the api, I couldn't change the settings for this user in Smart reporting. I only can change the thousand separator settings global for all users.In the attached file I send you a screenshot on which you see the behavior.

Please let me know if this helps identify the issue.


Regards,

Amir

photo
1

Hi Amir,

I think it'd be easiest to demonstrate the issue and show us how you're going about doing this, etc., on a screen share. The US office is out the rest of the week for a national holiday, but I've reached out to my global colleagues to reach out and correspond with you further and set up a time. Someone will be in touch shortly.

Regards,

Mike

photo
1

Hi Amir,


With the holidays in the US I'm picking this up from Mike. Is there a time that would suit for us to do a screen share so I can see what is happening here? I have used the embedded report API on my 7.3 version and I am seeing the below output (which is definitely pulling from my Yellowfin config which has '@' as the separator). I want to understand the context of this and see what other translations may be taking place.


/6b817e1c932eeeb621d52cc05a533c04


Cheers,

Neal

photo
1

Hi Neal,

Thank you for taking this over.

May I know your availability and what timezone you are working in?

Customer works in EMEA timezone, we can schedule a webex/call accordingly.


Regards,

Amir

photo
1

Hi Amir,


I am in Melbourne (GMT+10) and I am available from 9-4pm in our timezone Monday to Friday. Let me know if that works and we can go from there.


Cheers,

Neal

photo
1

Hi Neal,

We work in EMEA timezone. I don't think we could schedule a call in your timezone.

Can you just some time in EMEA timezone? Or you can assign this ticket to expert who works in EMEA Timezone.


Thanks,

Amir

photo
1

Hi Amir,


Can you please be specific with which timezone within the EMEA region you are looking to schedule a call and I will either organise this with you or pass this on to one of my colleagues in the UK if we cannot find a suitable time.


Cheers,

Neal

photo
1

Hi Neal,

I am available 8 AM to 11 AM and 1:00 PM to 4:00 PM London time daily Mon-Fri.

Please let me know your availability.


Regards,

Amir

photo
1

Hi Amir,


Thank you for that. Due to the timezone I will look to get one of our Northern counterparts to screen share with you on this. Once of the team will be in touch with your soon.


Cheers,

Neal

photo
1

Hi Amir,

I hope you are well! :)

This has now been passed over to the UK team and I have read through the ticket and am all caught up on it! I will be happy to jump on a screen share with you first thing Monday morning!

Let me know if 8am or 9am UK time works for you! And I will set that up and send across the details :)

Thanks & Best Wishes,

Lesley

photo
1

Hi Lesley,


Thank you for your response. I will confirm the time with Customer and let you know.

Thanks,

Amir

photo
1

Hi Lesley,

Customer is available now 8 AM UK time for a webex.

Please confirm your availability for the same and send a webex invite accordingly.

Regards,

Amir

photo
1

Hey Amir,

I hope you are well!

My apologies, this was a little short notice. I will be available again at 9:30, can you please ask your client if they are available at this time?

Also I will be sending across a Ring Central meeting invite I do not have a webex account.

Best Wishes,

Lesley

photo
1

Hi Lesley,


Sorry for the short notice. I got late response from customer.

I will be in another meeting at 9:30 AM UK time. Will 10:30 AM UK time works for you?

I will confirm this time with Customer as well and update you.

Regards,

Amir

photo
1

Hey Amir,

Not a problem, we will get a screen share booked for today! However, I will be in a meeting at 10:30.

My next available hours for today are as follows (then you and the customer can pick which time suits best) 11:30am - 12:30pm, 1:30pm - 5:30pm (Basically free all afternoon!)

Let me know a time between those mentioned above and I will set that up! :)

Thanks & Best Wishes,

Lesley

photo
1

Hi Lesley,

Thank you for your response.

I just confirmed with Customer, we can have a webex meeting at 1:30 PM UK time today.

Please send me a ring meeting invite for the same.

Thanks,

Amir

photo
1

Thats Great, Amir! :)

Ive booked that in, and you will find the ringcentral meeting details below!

Look forward to speaking with you at 1:30

Thanks & Best Wishes,

Lesley


Hi there,


Lesley-Anne Goggin is inviting you to a scheduled RingCentral meeting.


Topic: Lesley-Anne Goggin's RingCentral Meeting

Time: Dec 9, 2019 1:30 PM London


Join from PC, Mac, Linux, iOS or Android: https://meetings.ringcentral.com/j/1494315510


Or iPhone one-tap :

US: +1(773)2319226,,1494315510#

AU: +61283108040,,1494315510#

GB: +442038754507,,1494315510#

JP: +81645602947,,1494315510#

Or Telephone:

Dial(for higher quality, dial a number based on your current location):

US: +1(773)2319226

AU: +61283108040

GB: +442038754507

JP: +81645602947

Meeting ID: 149 431 5510

International numbers available: https://meetings.ringcentral.com/teleconference

photo
1

Thank You!


Regards,

Amir

photo
1

Hey Amir,

Thank you for joining the call earlier with your client -

I have tested this today and it did work for me, I was not able to replicate the issue using the same version/build of yellowfin. I have been trying to see why it is not working as expected for your client! I will continue to investigate and let you know!

Please see my screenshots below so you can see this working as expected for me.


b2c685c419497b2becd54d51b057d42e


359ed2e283013794c2df52124dd39287


1d0edd025b53bdf5ec0b79285c7bc959


My apologies that I have not figured out why this is not working for your client yet!

Best Wishes,

Lesley

photo
1

Hi Lesley,


Thank you for your quick response.

I will wait for your update on the same.

Regards,

Amir

photo
1

Hey Amir,

Update - I am still in the process of figuring out why this is not working! No luck as of yet.

Are you able to replicate the clients issue in smart reporting? perhaps?

I am continuing to look into this though and will give you further updates on my progress :) I hope that is ok!

Best Wishes,

Lesley

photo
1

Hi Lesley,


Thank you for your update.

In smart reporting console, we do see the required separator, however in embedded html page it shows different.

Please let me know if you have any update on this.

Thanks,

Amir

photo
1

Hey Amir,

Could you provide me with the applications you/ the client are using to embed?

I simple just used text editor on a Mac, and opened in the browser chrome.

Best Wishes,

Lesley

photo
1

Hi Lesley,

You can try to reproduce it on Windows machine with IE or Google chrome as browser.

Thanks,

Amir

photo
1

Thanks Amir,

I will start up my windows machine now and test this out!

Will update you shortly!

Best Wishes,

Lesley

photo
1

Hey Amir,

Could you get the client to try using this instead


<!DOCTYPE html>

<html>

<body>


*insert the embedding code here*

</body>

</html>


Because I cannot seem to get the report to embed in any way using the html code that your client used!


But when using the simplified version of the html code - this worked for me every time!

Please see screenshots below of my testing on a windows machine, internet explorer and google chrome! :)

a338070fc5b951b94dc0e5d0cd0f0f63

bd672916415140015b7ef7d593823333

Let me know your thoughts and if your client gives it a go?


Best Wishes,

Lesley

photo
1

Hi Lesley,

Thank you for your update.

I will share this with Customer and let you know.

Thanks,

Amir

photo
1

Thank you, Amir!

I look forward to the update :)

Best Wishes,

Lesley

photo
1

Hey Amir,

I hope you are well!

I just wanted to check in to see if this made any difference with the thousand separator and worked as expected?

If not let me know and I will continue to investigate!

Best Wishes,

Lesley

photo
1

Hi Lesley,

Thank you for followuing up on this.

I am awaiting customer response on this.

I will keep you posted.


Thanks,

Amir

photo
1

Hey Amir,

No worries! I will be keeping my fingers crossed that this has been resolved! :)

Best Wishes,

Lesley

photo
1

Hi Lesley,

Received below response from Customer:


Hi Amir


I tested the embedding of the report with the version which your R&D recommended. Unfortunately it makes no difference how I embed the report. It doesn't works. I received on both version the same response.

For me it look likes the error / bug is in the endpoint of the JsAPI: <server>/JsAPI?reportUUID=... are there any settings available for this JsAPI of Smart Reporting?


Thanks,


Please advice!


Regards,

Amir

photo
1

Hey Amir,

Thank you for updating me!

I have another question - though I will be reaching out to the rest of the team for help!

What are the language settings for your clients machine, browser and yellowfin?

Best Wishes,

Lesley

photo
1

Hi Lesley,

Hope you are doing well!

Got a response from Customer:

The language settings are as follows:


Client: English

Browser: English

Smart Reporting: English (Regional Settings in the User profile)

Please let me know the next action plan on this.

Thanks,

Amir

photo
1

Hey Amir,

I am thank you, I hope you are well too!

And thank you for letting me know the language settings.

I have received a response from the team which to sum up, it may be due to who is logged in to the AR Console when the embedded report is being ran. Once this is determined, the pertinent question would then be: is said user in default or client org, and does this user org have the thousand separator set to "'". It's certainly possible that when looking at the report from within Smart Reporting, they're actually utilising a different user and if that is the case, i think it possible the other user simply doesn't have the thousand separator configured in the same way.

Taking this into consideration - I then tested this out by doing the following -

  • created a client org
  • set default org thousand separator as ,
  • set client org thousand separator as '
  • created a report within default org
  • signed into client org and opened that same report, selected the embed link
  • embedded into a .html page

Results - Still not able to replicate the issue as I received the ' thousand separator in the embedded report.

After speaking with another colleague, could you please provide me the country/region your clients machine is set to ? - as this could possibly also make a difference.

Please also let me know your thought on this!

Thanks & Best wishes,

Lesley

photo
1

Hi Lesley,

Good News!!! Issue resolved!!! :)

Below comment from Customer:

Thanks for your input. I could solve the issue with the thousand separator. The problem was that the setting with the "siadmin" user wasn't set correctly. After I changed the thousand separator to the correct one by the siadmin user the embedded report was show it correctly.


Thanks for your support. From my site you can close this ticket

Appreciate your help on this

Regards,

Amir

photo
1

Hey Amir,

I hope you are well and had a lovely weekend!

That is really great news! Thank you for letting me know :) I am very pleased your client was able to resolve the issue!

I will go ahead and close the ticket - if you have any further questions, please do not hesitate to reopen, I will be happy to help! :)

Best Wishes,

Lesley