Problem with Custom query enry style for filters in YF 7.4

Miguel Roldan shared this problem 1 year ago
Defect Fixed

I have migrated to version 7.4 from version 7.2 and now I have a problem with the entry style for filter formatting within a report. When I select "Entry Style => Value entry method = Value list selection => Custom query" and I introduce the query, after I finish (see attached file custom_sql_filer_1.png), this "filter entry style" is not saved and is set again to "Manual user entry" (see attached file custom_sql_filer_2.png).

In previous version (7.2) this worked perfectly but now I can not get to set the entry style for the filter to custom query.

P.S.: Filters used in the report are created as automatic from a stored procedure

Comments (19)

photo
1

Hi Miguel,

This is a bug in the more recent 7.4 and 7.3 builds. This bug has been fixed and should be included in the most recent 7.4 build.

What build of 7.4 are you on? (System information section of admin console)

You mention that you migrated, did you transfer this content through import/export?

Regards,

Nathan

photo
1

Hi Nathan.

Build 20171031.

From which build is this bug solved?

And yes, I transfered this report through import/export.

Regards

photo
1

Hi Miguel,

When I tried this on the December build that came out a week or so ago, it worked as expected.

Can you try upgrading to that build (The upgrade installer only lets you upgrade from within 7.4 atm)

Nathan

photo
1

Hi.

I have migrated to the December build but unfortunately it still doen't work. I have done some test myself and I guess the bug has to do with automatic filters coming from a stored procedure. When I create a "normal" report from a view and set the entry style of a filter to custom sql, the configuration is stored and it works. BUT, if I create a report from a stored procedure view and set the entry style of a filter to custom sql, this configuration is not stored and the entry style is set to manual... I hope it can help...

Regards

photo
1

Hi Miguel,

Thanks for the clarification, this is actually the defect I remembered originally and my more recent testing was not appropriate to the real issue. Additionally looking through JIRA it appears that there was confusion on the dev end and this defect was marked as fixed, but the fix was for a different issue.

The issue is still raised with highest priority so we should see some movement on this in the next couple of weeks.

Regards,

Nathan

photo
1

Hi!

Does it mean it will be fixed in next release?

photo
1

Hi Miguel,


This will probably not make the next release, as soon as the devs get a chance to go through the updated defect, then it should be in the release ~1 month later.

I will keep you up to date.

Nathan

photo
1

Hi! Is this problem already fixed in any release?

Thank you.

photo
1

Hi Miguel,

Yes it looks like this was just fixed and should be available in the most recent 7.3 and 7.4 builds.

Let me know if it does not work in your tests.

Nathan

photo
1

Hello Nathan.

I have updated my version to last build (20180313) and it still doesn`t work. When I set the entry style of a filter of a report to custom sql, this configuration is not stored and the entry style is always set to manual.

I attach a file with some screens in case it could be useful.

Regards.

photo
1

Hi Miguel,

This works in my tests on that build, are you testing the query after defining it?

Nathan

photo
1

Yes, I have tested the query and it works. Even I can cache the results...

Have you tested the bug with a report from a stored procedure view? I think this is the key. As I said before, I guess the bug has to do with automatic filters coming from a stored procedure. When I create a "normal" report from a view and set the entry style of a filter to custom sql, the configuration is stored and it works. BUT, if I create a report from a stored procedure view and set the entry style of a filter to custom sql, this configuration is not stored and the entry style is set always to manual....

photo
1

Hi Miguel,

The bug that I originally mentioned was actually specific to stored procedures, but that has been fixed for a few months and should certainly be in your current build. (it worked with stored procedures in my tests)

Can you see if I am missing anything from my replication here?

Nathan

photo
1

Hi Nathan.

After watching the video, I think I know where the problem is. I'm appliying the entry style to a filter which comes from the stored procedure, not to a "normal" field. In your example, it would be "my_date", not "EventCode". For this kind of filters, the entry style is set always to manual. I have tried with a "normal" field (similar to "EventCode" in your example) and it works.

Please, try setting the entry style for "my_date" to "Value List Selection" and check. I guess the entry style will be set always to manual after saving it.

photo
1

Hi Miguel,

I'm stepping in for Nathan, as he's out this week.

I can confirm that this behavior you're describing is the same as in the Defect Nathan has mentioned. It looks like this fix will be part of the upcoming 7.4 release on May 3rd. Please stand by for an update on an official release date.

Thanks,

Ryan

photo
1

OK. I will check that release in order to confirm if the bug is solved.

Thank you.

photo
1

Thanks Miguel,

We'll check in with you here upon release.

- Ryan

photo
1

It works now.

Thank you very much.

Regards

photo
1

Glad to hear it!