No data retrieved by Stored procedure when drilling up

Syed Rahman shared this problem 15 months ago
Resolved

Hi Experts,

I have 2 reports in a dashboard

1. PNL Selection

2. PNL

PNL Selection report has drill down set. PNL Selection report and PNL report is linked with link drill down functionality in the dashboard. PNL Selection report is created using freehand sql view and PNL report is created using stored procedure.

When I drill down on PNL Selection report, a value is passed to PNL report as a filter (has 1 filter) and data is refreshed. But, When I drill up by clicking "UP" button available in report title section on PNL Selection report, the PNL report displays error as incomplete filters (Snapshot attached).

I think, the default values are getting disappeared while drilling up.

Regards,

Syed

Comments (10)

photo
1

Hi Syed,

Thanks for reaching out. I apologize for the delay on this... it's a bit of a bugger. I've been trying to set up a View and report built upon a Stored Procedure but am having some difficulty setting it up to where I'd have a Drill Down option, which is of course required to get the Up option on the dashboard. Do you think you could supply the Stored Procedure you've created so I can run that query on my end and try and get this replicated?

Thanks,

Mike

photo
1

Hi Syed,

I just wanted to check in and see how things are going with this. Do you think you could supply the requested info?

Regards,

Mike

photo
1

Hi Syed,

I'm going to go ahead and mark this one as Resolved since I haven't heard back from you, but if you have further questions or concerns on this, if you respond, it will re-open the case and put it back in my queue and I'll be happy to help.

Regards,

Mike

photo
1

Hi Mike,

Sorry for delay in response. We won't be able to provide the SP. I can explain you the scenario once again in detail.

I have 2 reports, one is designed with freehand sql and other using SP. The report with freehand sql contains drill down and its output is linked by drilldown to SP report in Dashboard.

The SP report has default value passed in the filter, what happens is; I drill down the freehand sql report (to pass the value as filter) to SP report but when I click on back (to go back) the default value which was set is lost and the SP report returns error Incomplete filter (screenshot attached).

I am not able to understand why the default value disappears which was set in the begining?

Regards,

Syed

photo
1

Hi Syed,

Thanks for the reply. It's going to take some time to build both a Freehand SQL and Stored Procedure report and test this. I hope to have something for you tomorrow, but regardless I'll let you know of my progress then.

Regards,

Mike

photo
1

Hi Syed,

When you say you're clicking back to go back, do you mean you're clicking the Back button in the browser itself and not something in Yellowfin's UI?

If so, this would indeed be expected behavior, as clicking the back button resends the URL, which makes it like the report is being run for the first time again.

In a normal drill setup there'd be a breadcrumb you can click to go back to previous stages of filtering, which should keep the values already inputted, but clicking Back in browser will not do this.

Regards,

Mike

photo
1

Hi Mike,

I click on "UP" button which is available in YF UI of drill down setup and not he browser back button.

Regards,

Syed

photo
1

Hi Syed,

Ah, okay. This actually sounds like a Defect we have logged. What build of 7.4 are you currently running? You can find this information under Application Details in your info.jsp file, which can be accessed by appending '/info.jsp' to your login URL. For example, localhost:8080/info.jsp. You can also find this info under Administration > System Information.

Thanks,

Mike

photo
1

Hi Mike,

I am on YF version 7.4.7 build - 20180824

Regards,

Syed

photo
1

Hi Syed,

When you say Drill Down, do you mean Drill Through? The issue is that I only see the 'Up' option when using Drill Down, but with Drill Down you can't Drill into a different report - with Drill Down you set a hierarchy at the View level, which means it'd be drilling into the same report/View. If I do set up Drill Through and place that report into a Dashboard and click one of the hyperlinks, it actually opens the child report itself, outside the dashboard, so there is no the option to click 'Up'.

So I can better replicate your setup, can you please send me a screenshot of what your page featuring the 'Up' option looks like as well as the full Data and Related Content stages in the Report Builder of your Parent report so I can see more of your setup and try and replicate?

Thanks,

Mike

photo
photo
1

Hi Syed,

I just wanted to check in and see how things are going with this.

Regards,

Mike

photo
1

Hi Syed,

I'm going to go ahead and mark this one as Resolved since I haven't heard back from you, but if you have further questions or concerns on this, if you respond, it will re-open the case and put it back in my queue and I'll be happy to help.

Regards,

Mike