Manual update of the translation file

Joan Poblet shared this question 2 years ago
Answered

Hi,


We must change the text "Salut {0}" that appears in French in the reports emailing/broadcast by "Bonjour {0}".


We upgraded our version from 20161024 to 20170413 because it was possible to change that text in the email template configuration.


Because of the problems we had with the upgrade (we are already discussing about it in another ticket), we had to revert the update to our previous version 20161024.


Once we are in that build and until we are able to update to the latest one, we would like to bypass the translation directly in the text files. We found that the French text file was /js/text/text_fr.js and we changed the text "mi.text.email.distribution.greeting":"Salut {0}" to "mi.text.email.distribution.greeting":"Bonjour{0}".


It appeared good but, after uploading the new js, restarting the server and cleaning the browser cache, when we tested it, the email was still sent as "Salut {0}".


Any idea on this topic?


Many thanks.


Best Regards,

Joan.

Comments (7)

photo
1

Hello Joan,


Once you made the changes to the .js file, have you changed the default language to another and then returned it back to French - or restarted the server?

This should force a reload of the file and hopefully pick up the changes.


I hope this helps!

Best regards,

Pete

photo
1

Hi Peter,


What do you mean about changing the default language? Changing the browser default language? It's how we force the YF language but I don't know whether you are referring to another way or not.


Many thanks!


Regards,

Joan.

photo
1

Hello Joan,


Yes, that is the way I meant, or by restarting yellowfin.


Please let me know how you get on!


Best regards,

Pete

photo
1

Hi Peter,


We already restarted the server and now have make both changes of default languages and it didn't work. :O


Maybe we are missing something.


Regards,

Joan.

photo
1

Hello Joan,


I have escallated this in support to see if I can find any answers for you.

Hopefully the new upgrade installer will fix your upgrade issue and this won't be an issue going forwards!


Best regards,

Pete

photo
1

Hi Joan,


I have had an update from the team:


Hey Pete,

they're looking in the wrong place, they need to update their ApplicationResources_fr.properties file which is in their i4core.jar file as explained in the following forum post:

http://www.japan.yellowfin.bi/YFForum-Multi-language-UI-options-?thread=89457

But make sure you remind them they will have to redo their change everytime they update YF.

Also, I think the label they need to change is "mi.text.email.template.hi" but I'm not sure about that....but they can easily experiment and find out which it is.


I hope this is of some help, please let me know if this resolves the issue, or if you manage to get the upgrade to function correctly with your install!

Best regards,

Pete

photo
1

Hi Peter,


We are going to try updating YF with the interim version you prepared and see whether everything works fine without needing changing i4 files.


I'll let you know once we have tested the update.


Thank you.


Regards,

Joan.