Linked Report Filter Not Applying During Auto Load

Jason Kaczmarek shared this problem 2 years ago
Defect Fixed

I have a main report with tabs to linked reports. The reports are based on SQL views.

  • When I turn on auto-load on the main report, the linked reports run automatically, but without the filters applied. Then when I click "Go" on the main report, this issue is resolved.
  • When I turn off auto-load on the main report, but turn it on for the linked report, the linked reports do in fact run, and the filters are correctly applied right away. It's nice that the data on the linked reports is accurate; however, I find it odd that the linked reports run even though the main report hasn't run yet.

This report was working fine in 7.1. It broke since 7.2. I'd like to leave auto-load on, but since users are getting bad data on the linked reports, I have it turned-off for now.

v7.3 (20170523)

Comments (12)

photo
1

Hi Jason,


Thank you for getting in touch. This issue that you are describing has already been raised as a defect, though this was limited to the fact that the linked report would auto load despite having a setting to the contrary. I will test the filtering symptoms you describe and add these tot he current defect ticket if I am able to replicate.


I should have a formal ruling for you in the next couple hours.


Regards,

Nathan

photo
1

Hi Jason,


Quick clarification here, are you linking the filters between the reports, or is the filter specific to the co-display report?


Regards,

Nathan

photo
1

Nathan,

I'm linking on filters. It's set of quarterly reports that link to year and quarter filters on the main report.

Jason

photo
1

Hi Jason,


In my tests I have not been able to replicate your filter application issue.


When the filters have no default value, both reports will auto-load with no filters applied. When a default value is set on the primary report, the filter link will work as expected.


Can you elaborate a bit on how you have this set-up and what I might be missing in my replication attempts?


Regards,

Nathan

photo
1

Nathan,

I have a SQL view that contains the following fields. All are setup as a dimension in YF except for Amount which is a metric.


  • Year - Int
  • Quarter - Int
  • Code - VarChar(4)
  • Amount - Decimal(15,6)

I created a Sub report on the View


  • Auto Load = False
  • Remember Filters = False
  • Year filter - Mandatory = True
  • Quarter filter - Mandatory = True
  • Code column
  • Sum(Amount) column

I created a Main report on the same View


  • Auto Load = True
  • Remember Filters = True
  • Year filter - Mandatory = true, Default = 2017
  • Quarter filter - Mandatory = true, Default = 1
  • Code column
  • Sum(Amount) column
  • Added the Sub report as a Tabbed Co-Display and linked the Sub filters to the Main filters

When I open the Main report, the Main report shows correct data. But when I click on the Sub tab, the Year and Quarter filters have not been applied. If I click "Go", or click back on the Main tab and then come back to the Sub tab, then the filters are correctly applied to the Sub report. So it's just the initial load of the report that has an issue.

Jason

photo
1

Hi Jason,


Thank you for the through clarification, I have been able to replicate this issue and have added this information to the current defect ticket.


I will keep you up to date on the status of this ticket, but please let me know if there is anything I can do to help in the meantime.


Regards,

Nathan

photo
1

Are there still plans to get this fixed?

Jason

photo
1

Hi Jason,

Sorry for the delay, this was fixed in the May release. Please let me know if upgrading does not resolve this.

Nathan

photo
1

Nathan,

I'm now on v7.35 b20170928 and this is still not working properly. The filters are not being applied to sub-reports during the auto-load.

Jason

photo
1

Hi Jason,

It appears that this may have only been applied to 7.3. I will dig a bit more into this.

Nathan

photo
1

This is now fixed in v7.35 b20171201

Jason

photo
1

Glad to hear it Jason.

I will close this.

Nathan