Javascript option not showing in Roles

Tal Mickel shared this problem 6 months ago
Resolved

Hey guys, Dor here


I did everything your guide says to do, and I cannot see the option for JS charts in roles

/NM9l++oAADok5sgCgAADBAQBQAACEAUAAAgAFEAAIAARAEAAAKIEAUAAAGIAgAABP8PNukXe1PspngAAAAASUVORK5CYIIA

Comments (28)

photo
1

Hi Tal,


Once JS charts have been enabled, the user/admin needs to log out and back in again to have the new role options appear.


Can you confirm you have done this?


Best regards,

Pete

photo
1

Hey Peter! Dor here


I tried that as well and I confirmed it did not work either.

Seems like a bug at our end, maybe the configuration got messed up due to installation from 7.2 to 7,4?

Is there any configuration we can change to activate that ?

photo
photo
1

Hi Dor,

Thank you for reaching out. To enable JS Charts, go to 'Configuration' from the 'Administration' tab, click the gear icon for 'System' settings, head to 'Security' and click the slider for "Javascript Charts":

6a2de736041f282e4efb2c0666961300

After doing this, when you head back to the Report Builder section in the Roles administration area, you will see "Javascript Charts" as an option under "Allow Freehand SQL Calculated Fields." Let me know if you find this okay.

Thanks,

Mike

photo
1

Hey Mike,


Thank you for your reply, this is very helpful

Unfortunately, as I stated - We've tried that, and still the option for JS charts under any role we try to edit does not exist.


Is there any other way to change that configuration ?

photo
photo
1

Hi All,

I think we've covered all of the options available in the Enabling JavaScript Charts wiki, except one, which is to enable Client Org Javascript Charts, which is also found under 'Configuration' from the 'Administration' tab > 'System' > 'Security', which may work. Can you also ensure "Public Reports" under 'Report Builder' is checked? I believe the JS Charts option is unavailable to users without access to create and edit Public Reports. After turning these on be sure to log off and log back on.

Regards,Mike

photo
1

Hey Mike, Dor here


I marked the Client Org option, logged out and in, and I want to create it on Admins at the current moment.

Public reports are marked there, yet, still, can't see the option.

/B7vVs7mAVBVNAAAAAElFTkSuQmCCAA==

photo
photo
1

Hi Tal,

Perhaps we can hop on a screen share tomorrow? I'm available from 8AM - 5PM MST.

Thanks,

Mike

photo
1

Hey Mike, Dor here


I can screenshare with you :)

How about Sunday, 8:30am MST ?

photo
1

Hi Dor,

Sorry, I'm unavailable that day. I can screen share M-F 8:30 AM US MST to about 4:30PM MST. Let me know what time best works for you within that time frame.

Regards,

Mike

photo
1

Oops, Sorry Mike, forgot that Sunday is a day off

Monday then! would be great.

photo
photo
1

Hi Tal,

I can set up a RingCentral Meeting for 10 AM MST, if that works:

Join from PC, Mac, iOS or Android: https://meetings.ringcentral.com/j/1489686621

Regards,

Mike

photo
1

Hi Dor/Tal,

Thanks for hopping on the call earlier. I've taken your Config DB that uploaded to our FTP server in November, ran the update installer (this being from 7.2 20170202 to 7.4 20180226), and I am seeing the Javascript Charts option.

So we have a couple options here:

  • We can either obtain a fresh copy of the Config DB experiencing this issue, or;
  • We can see if this is still an issue after resolving your upgrade tickets.
  • It's worth considering the browser as an option here as well. In the small chance it comes down to this, have you tried this in another web browser? What browser are you using?

Let me know how you'd like to move forward here.

Thanks,

Mike

photo
1

Hey Mike!


I can get a fresh copy, for that matter, although nothing has changed.. I'll update this ticket with it

The upgrade tickets are very important, while this ticket is also important for us..

I've tried to run it on Firefox (our default) and Chrome, nothing has changed...

photo
1

Hi Dor,

I ran the upgrade installer a second time for your 7.2 instance and am still seeing JavaScript Charts as an option, so unfortunately in regards to this particular issue, I do think I am going to need that updated Config DB. Please let me know when that is uploaded.

Regards,

Mike

photo
1

Hey Mike !

The updated DB has been uploaded to your FTP server :)

photo
1

Hi Dor,

Excellent. I will re-set up the instance using this config db and test against this when I get the chance.

Regards,

Mike

photo
photo
1

Hi Dor,

I installed your updated Config DB and I still see Javascript Charts as an option:

0bc625a36e111bdb7d8523ba5886c54a

I believe we've narrowed it down to some sort of local environmental factor. Can you see if this option is available in your account from a different computer?

Thanks,

Mike

photo
1

Mike,


I have an idea.

We're not using HTTPS, we're using HTTP.

And I know that there are some security problems with Java.

Could it be that it's being blocked because the connection is not secure?

Can you check HTTP and not HTTPS in our instance ?


**UPDATE* : I've checked it in HTTPS, there's no difference.I also checked it in another computer, nothing happened.


I have no direction to what can cause it in the environmental stance.

I'm looking at Yellowfin files in search for what unlocks this feature, and maybe get a clue from there.

photo
1

Hi Dor,

Assuming you don't find anything doing so, is your instance publicly accessible? Do you think I can have a temporary login to view the problem first-hand?

Thanks,

Mike

photo
1

Hey Mike

It's not publicly available, it contains sensitive information..

I can screenshare with you if you'd like, I'm available now

photo
1

Hi Dor,

Unfortunately, I don't think seeing the problem again would be beneficial here. Replicating it is really the only way we can work to find and address this issue. I think our final option would be if you could zip up your Installation folder and send that our way, then perhaps we can see if this in some way relates to one of the styling files. Other than that, we have your entire most recent Config DB set-up here, and this is working as expected, so we've pretty much narrowed it down to something that's particular to your environment. Let me know if you can send that over.

Thanks,

Mike

photo
1

Hey Mike,


I went ahead and zipped our installation folder :)

I've noticed now that there's an update from February and we had January.

We've update the system after I've uploaded our zip file, but note that there's no change inside roles.

I still cannot see the Java option.

photo
1

Hi Dor,

Thank you. I'm looking into this and will update you when I next get the chance.

Regards,

Mike

photo
1

Hi Dor,

I just noticed I didn't update you after installing your installation folder. I'm still seeing JavaScript Roles as an option so I think we'll have to re-check in on this after update installer is ran again with the planned fixes included. By the way, the most recent time you ran the update installer, which I believe was either yesterday or the day before, did you happen to check whether JavaScript Roles became an available option?

Thanks,

Mike

photo
1

Mike! Thank you for that reminder!

I actually have good news. Javascript has appeared in Roles, I was able to get it to work :)

photo
2

Hi Dor,

That's great news! It'd be interesting to know what you discovered here, but since this is working now, I'll go ahead and mark this as Resolved in the mean time.

Regards,

Mike

photo
1

Thank you for your help :)

photo
1

You're welcome!

photo