java.lang.UnsatisfiedLinkError: no sqljdbc_auth in java.library.path

Vidhya shared this question 3 years ago
Answered

I am trying to connect yellowfin with my local sql server. However I am getting the error that sqlijdbc_auth is not found. I have downloaded the dll file and I have placed the same in my system32 and jre folder. But this issue is still existing. Kindly help.

Comments (3)

photo
1

Hi Vidhya,


a few forum posts that I researched said the sqljdbc_auth.dll file should be added to the jre/bin folder, not the jre folder. And as well as that, a few of them said you need to set a -D system property called java.library.path that points at the directory containing the sqljdbc_auth.dll. If you are not familiar with the java -D switch, with Yellowfin you set it in the catalina script (<yellowfin home>/appserver/bin) if you are starting Yellowfin manually via the startup script, or if you are running Yellowfin as a windows service then you set it in the Java Options section of the Java tab of the service properties dialogue as shown below:


4ee27326916bf177b02e5491c30aedc8


Also, please make sure that you've chosen the correct X86 or X64 dll to correspond with the architecture of the JRE you are using.


I hope that helps, please let us know how it goes.


regards,

David

photo
1

Hi David,

Thanks for the reply. As you rightly said, I had put the wrong dll file into the bin folder. I had put X64 instead of X86. When

I corrected that ,it worked like a charm.

Thanks!!

photo
1

wow, that's great new to hear! And thanks very much for sharing it with us!


regards,

David