Issue with double quotes when export as text file.

Mohammad Rehman shared this problem 23 months ago
Defect Fixed

I came across issue when i add " double quotes around column it display the report correct column contents in double quotes. When I export as Text format it export the contents with three times double quotes around column contents.

For example:

I have added calculated field '"'+Incident Number+'"' and in display it shows the results "INC000000000123" and when i export the report to test format it exports as """INC000000000123"""

I am wondering why the exports adding extra double quotes.

It also includes extra quotes in column heading as well, if i change the column heading from Incident Number to "Incident Number" or ''Incident Number'' it also export as """Incident Number""".

How can we achieve this or this is defect.

We are using 7.1 (BMC version).

Thanks In Advance

Mohammad

Comments (6)

photo
2

Hi Mohammad,

When Yellowfin exports your data in text format, it will surround all text objects in quotes. However, this only explains two of the quotes. Since this still exists in the most recent build of 7.4, I am going to say that this is a bug and raise it as such.

Sorry for the trouble, I would suggest not using quotes in the mean time, or use a single quote '

Regards,

Nathan

photo
1

Thank you @Nathan_Schroeder as always for your time and help.

photo
2

Hi Mohammad,

Just wanted to let you know that this issue has been fixed. It is difficult to tell if this will make the May release, but if not it will be in the one after.

Regards,

Nathan

photo
1

Thanks Nathan,

No worries, we anyway depends on BMC to release the fix when ever they will feel to provide us after YellowFin release.

Regards

Mohammad

photo
photo
1

Hi Nathan

This works with single field. If I have more than one field in the report, then the result has double quotes multiple times.

Summary is field 1 and Inc is field 2 and below the result from csv export.


Summary;Inc "Backup DB Server for Moratorium Efforts.";""INC_CAL_1000004"" Can you please test this with multiple fields and let us know the results.

Regards,


Bharath

photo
1

Hello Bharath,

I am taking over this ticket from Nathan. I would like to replicate this and troubleshoot it further on my end but that would require me to know your build and version of Yellowfin that you are experiencing the behavior on.

You could provide this information by accessing the info.jsp page. You can hit this by navigating to http://<yellowfinURL>/info.jsp and grabbing a screenshot of the area pictured below.

/ZGYAAAAASUVORK5CYII=

This should better help me replicate what you're seeing.

Thanks,

Jared

photo
1

Hello Bharath,

I have been unable to replicate this in our current versions of yellowfin and require the aforementioned information.

I look forward to your response.

Thanks,

Jared