How to setTrend column in Report

Chandana K shared this problem 2 years ago
Defect Logged

Hi Team,

This is chandana.

I wanted to display Trend Image instead of Percentage Bar Formatter for metric in a report.

PI am unable to do that. Please find the attachment for more details.

Please somebody help me out.


Thanks in Advance,

Chandana

Comments (9)

photo
1

Hi Chandana,


Unfortunately there is no way to do this within a normal Yellowfin report, however this will be possible using a table created as a Javascript chart.


The fancygrid library allows you to easily embed charts into a table and works well within Yellowfin:


https://fancygrid.com/


I do not have a readily available, but when I tried this previously it was pretty easy to get going. Please let me know if this works for you or if you have any other questions.


Regards,

Nathan

photo
1

Hi Nathan,

Thank you for the Response.

I will try using fancy grid and Let you know the status.


Regards,

Chandana K

photo
1

Hi Chandana,


Sounds good, let me know if you run into any problems with this!


Regards,

Nathan

photo
1

Hi Nathan,

I solved the requirement using KPI Dashboard.

But I am facing one more problem with that. I created a KPI report and drag that report in to KPI Dashboard. Everything is doing good but the values which i tried to display using traffic light or up and down arrows (Beside the Title in the attached Image) are not displaying. Don't know where the problem is. Please find the image to know detail issue.

Please help me.

Thanks in Advance.

photo
1

Hi Chandana,


I realized afterwards here that you might be referring to the KPI functionality, so my apologies for not mentioning that. Regarding your most recent issue:

  • Do you see any errors in the JavaScript console (right click the page and then click "inspect" and navigate to the "console" tab)
  • Do you experience this in other browsers beside your current browser?
  • Are you able to use similar icons in conditional formatting elsewhere in the program?

Regards,

Nathan

photo
1

Hi Nathan,

Thanks you for the Response.


Here are the answers for your questions:

1) I have seen an error in JavaScript when I displayed reports in KPI Dashboard. Please find the image attached.

2) yeah I am getting the same error in other browser also ( I tried in Interner Explorer).

3) I am using the similar icons for other reports also and those are displaying for reports.


Regards,

Chandana K

photo
1

Hi Chandana,


Sorry for the delay here and thank you for the response. I have been attempting to replicate this issue, but have thus far had no luck.

  • Do you get this error when accessing Yellowfin from another computer? (Typically this type issue is related to a bad reference specific to the environment the user is accessing from)
  • What version and build are you currently on?


Hopefully something here will help us narrow this down.


Regards,

Nathan

photo
1

Hi Nathan,

Yeah I tried to access in another computer as well, I am getting the same error.

I am using yellowfin 7.35 V and Build type is FULLVERSION.


Regards,

Chandana K

photo
1

Hi Chandana,


Thank you, I was able to replicate this issue and have raised a defect to address it. (6458)


I will keep you up to date on the status of this ticket, but please let me know if there is anything else I can do in the meantime.


Regards,

Nathan

photo