How to format Numeric Display chart as percentage?

Stephen Johnson shared this problem 20 months ago
Defect Fixed

I have created a calculated field that is formatted as a percentage. When I add that field to a Numeric Display chart, it is no longer formatted as a percentage. How can I get it to format as a percentage?

Comments (6)

photo
1

Hi Stephen,

Thank you for reaching out. You've stumbled upon a bug here that is set to Highest priority and is actively being looked at. I think testing is actually complete and is under review. Nevertheless the build this fix may be included in is at least a month and a half away. Fortunately, in the meantime there is a relatively simple workaround.

Instead of using the Percent formatter, keep the format set to Numeric, and put % in the suffix, like so:

d3dfa90b0d99953b96b782bff86b5bc0

Now it shows up correctly in Numeric Display Chart:

dc64380f53eff321b7c6185700a9396d

Please let me know if you have any further questions.

Regards,

Mike

photo
1

Thank you. It is good to know the fix will be out soon.

photo
1

Hi Stephen,

Indeed. I've set this to Defect Logged, so that when it's marked as Closed in our internal system I'll be prompted to let you know the fix version is available.

Regards,

Mike

photo
1

Hi Stephen,

Just updating you this has been marked as fixed and will be included in our next build 7.4.6, which will likely be out mid-June. I'll let you know when the new build is published.

Regards,

Mike

photo
1

Hi Stephen,

As per our phone call, a more specific update regarding this... The details for this fix are as follows: "Resolved an issue where numeric charts were not formatting metric values with data level formats." This leads me to believe this won't just fix percent formatting, but other formatting choices in the Data section of the report builder as well. So, good news here, I think! We'll of course have to test this when 7.4.6 is published. As previously noted, I'll let you know when that is.

Regards,

Mike

photo
1

Hi Stephen,

Stepping in for Mike as he's out on vacation this week. I'm happy to inform you that this is marked as fixed for our current releases of 7.3.12 and 7.4.6, available on our Latest Builds page. Please let us know if you have any issues.

Thanks,

Ryan