How to broadcast a Private Report to Users

Mansi Sharma shared this problem 1 year ago
Resolved

Hi Team YF,


I have a report which is Private (Report -> Save ->Report Settings -> Report Access -> Private) and Private Report Security setting has some users assigned.

Now i want to enable a Auto Broadcast this report to few users (have permissions assigned) but i do not see Distribution Security option to enable Email option.


Please help me on how can i achieve this - its pretty critical.


Thanks,

Mansi Sharma.

Comments (6)

photo
1

Hi Mansi,

there is a Role Permission called "Email Reports", if this is not enabled then you won't see the Email option in the Distribution tab:


/w9g2rhS00mCXgAAAABJRU5ErkJgggA=


/+PWfoPxrbkzZrpfp8AAAAASUVORK5CYIIA


regards,

David

photo
1

Hi David,


I have "Email Report" option enabled -

bf6a2eaab8e9cd6eb5194dc15a710398


But my report is a PRIVATE Report and if it make any report Private - Distribution Security option disapears.

8c84bda1272d409f6af6ed8a61f29807


Please help me understand how can i distribute a Private report to the users who have access to this report.


Thanks,

Mansi Sharma.

photo
1

Hi Mansi,

thanks for the images, I am wondering whether this might be a bug specific to the build of 7.1 you are using. The reason I say this is because when I test this out over here there is no missing Distribution Security when a report is Private. I have attached a short video to demonstrate this to you.

Could you please tell me which build of 7.1 you are using?

Also, could you please check in the browser console whether there are any javascript errors when you are on the Distribution Security screen.


regards,

David

photo
1

Hi Mansi,

just wondering how you got on with this issue?

regards,

David

photo
1

Hi David,

I found the work around for this problem - So in 7.1 (2014 ver) first i needed to enable the broadcast and then make the report as private. When i make the report private -Distribution Security option goes away but Broadcast option is still available.

Thanks,

Mansi Sharma.

photo
1

Hi Mansi,

ah that's an interesting workaround, well done!

Thanks for letting me know.

David