How does Current filters work in Share Report Functionality?

Bharath Kumar shared this problem 3 months ago
Defect Logged

Hi Team,

I see a behavior where share reports url does not consider the current filter values. We don't want to set default filters, we want the actual values. We did attach a small doc, so you can see what we do.

Try to test it by sharing the report with one filter setting and then set a new filter or clear it, log out and click the shared link. Your report will consider the new filter values saved in the report. Is this expected or a defect? Even if you configure the report not to save the latest filters, the filter in the URL is being ignored.

Comments (7)

photo
1

Hi Bharath,

I would call this a defect, and in fact have raised product defect YFN-10074 against it so that it will be fixed.

Thanks for alerting us to this issue and apologies for the inconvenience caused by it.

regards,

David

photo
1

Hi Dave,

Thanks for that, do you have any ETA for this?

-Bharath

photo
1

Hi Barath,

just one thing, I didn't test this with Filters->Actions->Remember Filter Values = off because you said that even if the report were configured not to save the latest filters the issue still exists, however I just tested this now and I found that setting Remember Filter Values to be off definitely resolved the issue for me.

I have attached a short video to demonstrate this to you.

Please have a look at the video and let me know what you think.

regards

David

photo
1

Hi Dave,

I will try this out and let you know how it goes.

-Bharath

photo
1

OK Bharath, I await with interest to find out how it goes....

photo
1

Hi Dave,

it does not work for me :(

-Bharath

photo
1

Hi Bharath,

this means that, in effect, there is no workaround for you for this defect, and therefore the implication of this state of affairs is that the priority of the defect must be raised. So I have gone ahead and raised the priority of product defect YFN-10074 to HIGH.

regards,

David