How can I stop filters from caching during the import?

David Registro shared this question 3 years ago
Answered

When I import content, the filters are caching behind the scenes, so it's taking ages. How can I stop filters from caching during the import?

Comments (1)

photo
1

As of 7.1 (Jan 2017) and later, you can now skip the filter cache process, by adding a flag to the Yellowfin DB.

To do this;


  1. Stop Yellowfin

2. Run the following against the Yellowfin DB:


  1. insert into configuration (iporg, configtypecode, configcode, configdata) values (1, 'SYSTEM', 'SKIPIMPORTCACHEPOPULATION','TRUE');

3. Start Yellowfin and do your import.

NOTE: You will need to manually refresh these filters post upgrade (or have the schedule run).