Getting Filter Pane/Window to stay on side on dashboards

Zack Wilson shared this problem 42 days ago
Defect Logged

For some reason, on dashboards, I cannot make the filter window to stay on the right side. It tends to drop down below on smaller screens. How can I make it stick?


-Zack

Comments (5)

photo
1

Hi Zack,


Thank you for your question. In the global Content Settings for Dashboards, it might be worth playing around with the width of the Dashboard, as a percentage rather than a fixed pixel width. Are you able to confirm which version of 9 that you are experiencing this behaviour in? Are you also able to confirm if this is an issue that you are experiencing with canvas Dashboards, or with Dashboard layouts?


Kind regards,

Simon

photo
1

Simon,

Below is the version I am running. And... We are running by %. Some users are getting confused because they cannot find the filter pane.


Release Version: 9.2
Build Version: 20200805


-Zack

photo
1

Hi Zack,


Thanks for passing that information through.


  • What percentage width are you running at? It might be worth seeing if reducing this to 80% or lower helps. I believe the Dashboard width calculation might be based on the main body of the Dashboard, rather than the inclusion of global content on the two sides
  • What are the screen resolutions that you are having trouble with? Are they mobile devices by any chance?
  • Alternatively, it might be worth orientating the filter content horizontally via the filter properties setting, or using the 'left filter' rather than the global filter widget

Kind regards, Simon

photo
1

Simon,

I have tried quite a few things in trying to get it to stick. However, I think my best solution is changing it to left.


Hopefully, this will get looked at in the future?


Thanks,

Zack

photo
1

Hi Zack,


I've just given it another shot, and I've managed to replicate the issue with a different Dashboard, with consistency. It looks like this issue was flagged as fixed for 9.2, however, there looks like there is still work to be done here.


I've gone ahead and re-opened the Developer Task, where I will keep you updated on the progress here.


In the meantime, using the left-hand global content container looks to be the best workaround for the moment.


Kind regards,

Simon