Filter option missing when creating a report

Ed Moore shared this problem 2 years ago
Resolved

Hi, I know i've probably done something wrong, just not sure what.


When creating a report, I don't have the option to allow the user to filter by fields which normally appears underneath the "Sections" section.


Screenshot attached.

Sorry if not providing enough information, I'm not sure what else to include.


Ed

Comments (3)

photo
1

Hello,


this sounds like the user or more specifically the "user group" doesn't have permissions to see or use the filter options.


To change this setting, navigate to:

Administration | Admin Console | Roles | <role group>


click on the "report builder" section and make sure that the "custom query filters" box is checked.


This should resolve your issue.

Best regards,

Pete

photo
1

Hey,


Thanks for your reply!

When attempting the action, I am an administrator so I should have permission to do that. Could it be related to the way it was setup (in a view rather than straight from a report)?


Ed

photo
1

Hello Ed,


Sorry for the delay!

Yes, the order in which actions are applied in yellowfin is very important.


If possible, can you test a demo report with a different view with the permissions in the report?


Best regards,

Pete