Error choosing broadcast frequency option in French language

Joan Poblet shared this question 1 year ago
Answered

Hi,

Our French customer has pointed out an issue in the broadcasts configuration regarding the localization: when the browser and, consequently, Yellowfin is set either to English or Spanish, the frequency options displayed are the same:

0bb1705b2d908c252a989264651e61e5


8b3517278f8df3199ecd67a0c937f566

But when Yellowfin is set in French, less options are displayed:

23ec980e9a7c7feade0f0f849dd961eb

How can we solve this issue?

Our version is 7.35 with the build 20170928. We have tested it in Mozilla Firefox.

Thank you very much.

Regards,

Joan.

Comments (16)

photo
1

Hi Joan,

so far I have not been able to reproduce this issue over here. And I made sure that I was using the same version and build of Yellowfin as you (and I tried in Firefox and Chrome). I have attached a short video of my failure for you to see.

However, I did notice one strange behaviour - if I just set the browser language to French, but kept the Yellowfin language as English, then the whole application was translated to French except that drop-down list for Frequency which was still in English! Then if I changed the Yellowfin language to French (as well as the browser language) then finally, the Frequency values also were translated into French.


So, because of this observation I ask of you to please try setting the Yellowfin language to French (User Profile Settings->Regional Settings-> Preferred Language) as well as the browser language:


/A5hT5xMSbCJyAAAAAElFTkSuQmCCAA==


And if that doesn't do the trick, then could you please send across the i4-core.jar file (which you'll find in <yellowfin>\appserver\webapps\ROOT\WEB-INF\lib). Please change the file extension so that it doesn't say .jar, this is to avoid the mail server blocking it.


regards,

David

photo
1

Hi David,


I don't see the option "Preferred language". I see the other three options in "Regional settings" but not the one you asked me to use. Why is it happening?

Thank you.

Best Regards,

Joan.

photo
1

Hi Joan,

sounds like you don't have the Multi-Language Deployment option turned on. You will find this in Administration->Configuration->Region->Language Settings->Multi-Language Deployment:

/COA4YNEAAMAoG4QwFBTCGDAERDAAACoGwQw1BQCGHAEBDAAAOoGAQw1pcYC2JtvX3y3lfxu68X38vv6FQSOAQEMAIC6QQBDTamxAAbUBwIYAAB1gwCGmkIAA46AAAYAQN0ggKGmEMCAIyCAAQBQNwhgqCkEMOAICGAAANQNAhhqCgEMOAICGAAAdYMAhppCAAOOgAAGAEDd+BY4ZU76dw44fgQwAAAAADAJAQwAAAAATEIAAwAAAACTEMAAAAAAwCQEMAAAAAAwCQEMAAAAAExCAAMAAAAAkxDAAAAAAMAkBDAAAAAAMAkBDAAAAABMQgADAAAAAJP8fwimu4iQSxwIAAAAAElFTkSuQmCCAA==


You must turn this option on and then add some languages that will be relevant to your users.

After doing this, then you will find that the "Preferred Language" option will be displayed in "Regional Settings".


regards,

David

photo
1

Hi David,

What consequence would that option have in the regular users different than administration profiles (report writers, report readers)? They could do something that they are not allow to currently? Or they would need to update their profile to set the proper language? I would like to know if turning that option on could generate collateral effects.

On the other hand, please find the i4-core.jar attached.

photo
photo
1

Hi Joan,

when you turn on Multi-Language Deployment that means it becomes possible to change the language of the application (the labels on the buttons, menus etc), and also it allows Content Translation to be done (the translation of user-entered data such as column headings, filter names, report titles etc.)

If you don't want a user to be able to change the application language for their profile then you can hide their access to their profile:

/qQP8iXdYgigAAAAASUVORK5CYIIA

so this would prevent the possibility of someone who only knows french accidentally changing their default language to german and thus not being able to use Yellowfin.


And similarly there is a role permission to turn off Content Translation which you can use if you don't want a user to be able to create a translation file for the user-entered data:


/865+wAAAAAElFTkSuQmCCAA==


One more thing - as you know, a user can already change the default language in their browser settings. Well, Yellowfin will follow the browser's default language setting except if there is a default language configured in the User Profile in which case that will take precedence over the browser's default language.


regards,

David

photo
1

Hi Joan,

I'm just wondering whether you've had a chance yet to try out my previous suggestion of setting the Yellowfin language as well as the Browser language in order to resolve this issue? And if so, then how did it go?

regards,

David

photo
1

Hi Joan,

there has been no response to my previous post to you a month ago so this ticket will be closed now.

However, if you ever want to reopen it, then all you have to do is to add a new post to it and that will automatically change the ticket's status to "In Progress" which in turn will place it back again in our work queue.

regards,

David

photo
1

Hi David,

I'm so sorry for not replying you before.

We are currently trying to test your solution and we have realized that, as administrators, we don't have the "Language settings" section in the configuration "Region" tab:

/B4Enf8sC1oXgAAAAAElFTkSuQmCC

Therefore, neither we can activate the "multi-language deployment" option or access/activate the user language preferences settings.

How could we activate the access to the "Language settings" sections?

Thank you very much.

Best Regards,

Joan.

photo
1

Hi Joan,

I tested it out and found that it the following permission must be turned on to enable the Multi-Language Deployment option in Admin->Configuration->Region

/865+wAAAAAElFTkSuQmCCAA==

regards,

David

photo
1

Hi David,

Thank you, I was able to activate the language settings. After finishing all the steps, I'm still seeing only 3 broadcast frequency options in French.


I'm going to ask my infrastructure colleagues for the jar you asked for and then I'll get back to you.

Thank you very much.

Regards,

Joan.

photo
1

Hi Joan,

I just thought I'd let you know that after all these months I decided it would do no harm for me to try again to replicate this issue...but unfortunately it was the same as before - I had all of the Broadcast Frequencies. I have attached a short video to show you how it is for me. I used the build you were using at the beginning of the year, 7.35 20170928, and my Firefox is version 62.0.

I was also using the i4-core.jar file that you attached in February this year.

Obviously there must be some other factor that is different in your customer's environment than in mine. So please tell me what OS they are using, what version of java, and if you can think of anything else that might be significant please let me know.

regards,

David

photo
1

Hi David,

Thank you very much for checking it again.

Actually, we have tested in the version you told me and also in the version:

Application Version:7.4Build:20180515

Because we are planning to upgrade from 7.35 to 7.4 during next weeks.

We still have the same problem in both versions, even after having configured both YF user's language settings to French and the browser too.

I'm attaching the jar from v7.4 now because, at this point, we would like it worked in the 7.4 version.

Let me know how we could proceed.

Thank you.

Regards,

Joan.

photo
1

Hi Joan,

that i4-core you sent doesn't work in my 7.4 20180515, when I try and log in I get the following error:

/o7WvDzat14NVPOnfYMSWs27Z1U8jo7u282wzHL2cZO1r+bwxfu2rstq93W3zftF88VFyJKX4H9vBOW7Z1Xf26NpX9XkBwA02hUkJAMAESEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHRISgAAdEhKAAB0SEoAAHT+D7TOYtVgdj1LAAAAAElFTkSuQmCC


I don't know why, are you sure it's from 7.4 20180515? Maybe it got corrupted when I downloaded it.

But anyway, I continued my test with 7.4 20180515 using my original i4-core.jar and there was no problem there, I had the full set of 10 french frequencies:

/V68f+f5j8AAAAASUVORK5CYII=

Could you please tell me what OS you are using, and what version of Firefox?

Also, are there any javascript errors in the browser console when you don't get the full set of 10 french frequencies?

Does the french problem exist when you use Chrome?

thanks,

David

photo
1

Hi Joan,

I am just letting you know, that I am taking over this ticket from Big Dave. Are you able to provide an update as to where you currently stand with the french broadcast options and the frequency issue you were having.

Thank you,

Paul

photo
1

Hi Paul,


We have just tested it again and it seems it is working fine right now. May you close the ticket?


Thank you very much for your help.


Regards,

Joan.

photo
1

Hi Joan,

This is great news. I will close this off for now, but if you need anything else, please let me know.

Regards,

Paul