Drill Through - Hidden Drill Filters

Craig Dubin shared this problem 6 months ago
Defect Logged

Hi there,

I'm working on a 4-report drill through and it works great if I set the Drill Filters under formatting to be "Open". When I select closed or hidden, the master.field doesn't seem to be passing the child.filter properly. As soon as I set everything to "open" under this setting, it works fine.

The lowest level drill through report would be a lot of data if for example, they removed one of the constraints from the higher level reports.

I'm wondering if maybe there's a global or view-level setting I'm missing.


Thanks!

Comments (9)

photo
1

Hi Craig,

What kind of filters are you using here, e.g. does it matter whether you use a date filter or a list or does the same problem occur no matter what kind of filter is used?

If you're happy to, please could you send over a quick video demonstrating the issue.

Kind regards,

Chris

photo
1

Chris,

I put together a short (6m) video walking you through what I'm seeing.


https://rfta.webex.com/rfta/ldr.php?RCID=f1e36bb00345383b984d05c985af32d8

photo
1

Hi Craig,

Thanks for sending through that video! It looks like possibly there's a problem with the way the 1st and 2nd reports are set up. I can see in the 2nd report you have Route Group configured as a filter. Is that correct? Because the drill from the 1st report drills to Route, rather than Route Group.

It's possible it's not as simple as this, but that is the major difference I can see between all the reports in the video.

Kind regards,

Chris

photo
1

Hey Chris,

Hmm, I can see why that might appear that way, but I have a filter group called Route Group for all the reports. Route is one of the filters within the Filter Group. So the route field should be bound to the route filter within the route group, filter group.

photo
1

Hi Craig,

After a bit of digging, I've discovered that this is actually somewhat of a bug - the Closed and Hidden settings actually don't currently work and selecting any of the options has no effect, so you're best keeping them on 'Open' until the defect is fixed. I'll link this ticket to the internally logged bug so that you receive updates as soon as they come in!

Kind regards,

Chris

photo
2

Ah, gotcha. Well that's unfortunate because I'm worried about users accidentally removing a filter on a huge data set, but it's fine. I'll make sure they're aware to be careful with that. Thanks for the attention on it, Chris.

photo
1

No worries, Craig! Quick question, can I ask which company you work for or are associated with? It'll help us track the issue internally a bit better.

Kind regards,

Chris

photo
1

Hi Chris, Roaring Fork Transportation Authority (RFTA). It should be under my work email cdubin@rfta.com. I think i need to reach out to my CSM, because I can only get in through my old email from my old job that had YF.

photo
1

Hi Craig,

Thanks for letting me know!

I'll move this over to defect logged for now.

Kind regards,

Chris