Date filter default value problem

Bogdan Kiselitsa shared this problem 1 year ago
Defect Fixed

Hi,


In latest version of YF, 7.3+, we found an issue while building reports.


Issue:

Whenbuilding a report and implementing a user-prompt date filter with a defaultvalue the builder does not retain the default value selected. The result isthat when building the report it brings in data from all time, placing load onthe database and application.


Stepsto Reproduce:

Createnew report.

Draga date field into the filters pane.

Clickon the filter format button (or on the drop down next to the date field andselect Format).

SelectEntry Style and change the Value Entry Method to "Value ListSelection".

Usethe default value drop down to select a default time period. E.g."Yesterday".

Closethe Filter Formatting pane.

Introducea column into the report.


Result:

Thedata shown in the report builder is not filtered to the default time periodselected.

Ifyou open the filter formatting pane and check the default value selected is hasreturned to "--Omit--".


Please advise.


Regards,

Bogdan.

Comments (2)

photo
1

Hello Bogdan,


Thanks for reaching out with your issue. I can confirm that this is a logged defect that is marked as fixed for our upcoming June End of Month release. I'll mark this as Defect Logged until the release containing the fix, at which point I'll notify you of the release.


Thanks,

Ryan

photo
1

Hi Bogdan,

I wanted to reach out and let you know that this is fixed in our current releases of Yellowfin.

Thanks,

Ryan