Dashboard export does not include reports with Freehand SQL as data source

Sam shared this problem 6 months ago
Defect Fixed

I am exporting a dashboard and re-importing in our production environment. I notice that two reports are omitted from the export and are flagged on re-import as "The report <name> will be skipped." They both have Freehand SQL as the data source so I'm guessing that's the cause.

It seems to be the same as Problem 1 of this bug report acknowledged in 2014: https://www.yellowfinbi.com/resources/forum/yfforum-problems-with-exporting-freehand-sql-reports-in-yf-7-1-thread-176758 Do you know if that bug was patched / can you advise on how to integrate those reports into my dashboard in the other environment?

Thanks,

Sam

Comments (9)

photo
1

Hi Sam,

Thanks for contacting Yellowfin. It does seem like there was a very long standing bug which preventing exporting Freehand SQL reports under some circumstances. This bug as been reported as fixed in the upcoming bugfix release of Yellowfin, 9.7.1. Which version of Yellowfin 9 are you using currently?

Kind regards,

Chris

photo
1

Hi Chris,

I'm currently using 9.7.0.3. Good to know this will be fixed. Do you know when this release will come out?

In the meantime, I'm trying to deploy this dashboard this week and get customer sign-off, so I'll probably see if I can manually transfer and re-integrate those reports.

Thanks,

Sam

photo
1

Update: The freehand SQL reports don't appear on the export page when I search them by name, so I guess I cannot keep export them and re-add to the dashboard as a workaround. I will notify my customer and await patch version 9.7.1.

Sam

photo
1

Hi Sam,

Thanks or letting me know. The next patch should hopefully be next week.

Kind regards,

Chris

photo
1

Hi Sam,

9.7.1 was released last night and is available for download. If you want to test this version, you can grab it from our Portal.

Let me know how it goes.

Kind regards,

Chris

photo
1

Excellent! Thanks for letting me know. The application specialist who supports the Yellowfin backend here says he'll upgrade next week, I will give it a shot then and report back.

photo
1

No worries! Do let me know.

Kind regards,

Chris

photo
1

Yes this bug has been fixed! This ticket can be closed. Thanks Chris and to the devs for patching this.

photo
1

That's great to hear! Enjoy the rest of your week.

Kind regards,

Chris